NewBeetle.org Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
Hello, I have a 2001 GLS auto with 60000 miles, i've only had it for a week and I love it, the only thing is the EPC light and CEL light is giving me codes of 1171, and 1542. I'm about to change the TB but what i need to know is, do I need to do anything after I install the TB? I heard something about adaption or TBA, also are there extended warranty companies out there that can be trusted for an extended coverage?
 

·
Registered
Joined
·
4,271 Posts
Hello, I have a 2001 GLS auto with 60000 miles, i've only had it for a week and I love it, the only thing is the EPC light and CEL light is giving me codes of 1171, and 1542. I'm about to change the TB but what i need to know is, do I need to do anything after I install the TB? I heard something about adaption or TBA, also are there extended warranty companies out there that can be trusted for an extended coverage?
Both are throttlebody codes but could also be a few other things. Those two codes always seem to show up together.
You may want to take off your Throttlebody and clean it with some Electronic Cleaner. Also pull your IAT (Intake Air Temp) sensor and clean it. Should be right past the Throttlebody blades close to the throttlebody. Sometimes that thing gets pretty dirty. I would also check your Coolant Temp Sensor. See if has been changed from the old type Black unit to the new Green type.

If it hasn't than switch to the green one.
Volkswagen New Beetle 1.8T > Search > Temp Sensor > ES#1484 Coolant Temperature Sensor With O-Ring & Clip - 078919501CKIT

Also if you haven't already change your transmission fluid ASAP. Those automatic transmissions are ticking time bombs and changing the fluid may keep it going.
Here is an interesting article:
VWVortex.com - Heads-up: VW "Lifetime" auto transmission fluid (baloney!!!)!!!)

Hope that is enough to get your started and WELCOME to the ORG.

http://newbeetle.org/forums/new-member-forum/51021-newbie-welcome-kit.html
 

·
Registered
Joined
·
47 Posts
Discussion Starter #3
Thanks, I cleaned the TB and I do have the green temp sensor, but I will check the other sensor by the TB and I am sooooo scared of changing my trans fluid because its ok, but I will do it after the holidays...
 
1 - 5 of 5 Posts
Top