NewBeetle.org Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have had my bug for about a year now and I just started having a problem with stalling and idling. About 2 weeks ago I started having a rough idle and it would stall while going around turns or at low speeds. I though it was the maf going bad. While driving on the highway it started to loose power and then stalled. I turned it off with the car still moving and it would not start back up. I ended up pulling over and got it started, by giving it a lot of gas. I had then moved it off the highway and waited 10 min before starting it again. It started up fine after the 10 min and did not stall on my hour and a half ride home. Anyone know what the problem could be???? My dad who is a mechanic said when he drove it it seemed like the tps.
 

·
Registered
Joined
·
11,627 Posts
Have you scanned the car for trouble codes? Please post the codes up here. A common issue with the 2.0L; is the throttle body will get dirty and cause idle issues. You could try cleaning the throttle body and aligning it, see if that helps. When was the last time; a basic tune up, was performed on the car (e.g. plugs, wires, fuel filter, air filter, etc.)? You really need to get a scan tool; to diagnose these cars, otherwise you are pretty much flying blind. You might check out a VAG 401 or a cheap ELM 327 obd II wireless adapter and a app like OBD FUSION, for your portable device (smartphone or tablet: bluetooth version for Android and WiFi for Apple/iOS).

https://www.obdsoftware.net/software/obdfusion

Both of these are available; on amazon.com.
 
1 - 2 of 2 Posts
Top