NewBeetle.org Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey all so I had multiple cylinders misfiring a week ago. I found the vacuum hose cracked that runs from the side of intake manifold to the fuel pressure regulator. I replaced it and after driving it about 10 miles the MIL turned off and the car ran fine. A week passed with car running perfectly fine then today MIL comes on and car starts misfiring again. Should I just change coil pack? Spark plugs were done about 10,000 miles ago if that.
 

·
Registered
Joined
·
2,501 Posts
Ignition coil

Common failure in the 2.0 is the ignition coil. It might look good to the naked eye but in reality it might have hairline cracks. good luck to ya :bigthumb: new fellow member.
 

·
BillyJoel
Joined
·
56 Posts
Misfire

Feel free to take a look at my posts about the issues I had. My 2.0 had alot of missfires. I did have an issue with the coil pack but I had alot of others as well! Any questions just drop a line and check out my posts. Also, the people on here are truly helpful. I got a lot of good advice from esse10, Smileybug, and IndyTom.....this site is very good with the help and advice from others and posts.
 

·
Registered
Joined
·
3 Posts
Misfire codes, check 02 sensors.

My 98 NB had a CEL and misfire codes. Changing O2 sensors and clearing the codes fixed the problem. Luckily no issues with coilpack on mine. Bad O2 sensors affects the fuel trims which can cause misfire issues.
 

·
Registered
Joined
·
49 Posts
Take a spray bottle with water in it and spray the coil and ignition wires. If it starts missing worse than before, then you have a bad coil and/or wires.
 

·
Registered
Joined
·
103 Posts
99 beet 2.0

have a 99 2.0 beetle went through 12 maf under warrenty n they called tech n replaced all the wires n the maf going to the brain ( computer) n it was fine for 7 yrs till it kept popping missfire codes we changed plugs wires coil n it popped those codes again my buddy played around n replaced the maf the maf plug n wires from the plug n its great once again the wires n connection seem to b a problem on the maf it worked for us over a yaer so far no codes
 
1 - 10 of 10 Posts
Top