VW Beetle Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
We have put lots of money into our "Helga" and she has been great up until this last weekend. Drove it most of the day, came home and parked it then when I went to leave again it wouldn't start. Cranks, the oil light beeps and comes on after we try to crank it over also, it has proper oil level, has a good charge, fuel pump is kicking on, so I would assume fuel is getting to the engine. We have new plugs and replaced a few other things that were suggested for similar issues as it just didn't seem to be sparking, new relay being one of them. We cannot get any codes as it wont run for our code reader to be used. We have had codes in the past that made us worry the ECM/ECU was going bad. My questions is, we can get an ECU ourselves but not sure about how to get it coded or if its off the same year make and model does it need to be re-coded? Any help/ideas on what it could be appreciated!! Thank you!
 

·
Registered
Joined
·
14,350 Posts
What happens, when you try to scan for trouble codes? If you have a aftermarket stereo; that can cause, the problem with the scan tool working, what scan tool are you using?

The basics, should always be checked: trouble codes, fuel pressure, spark at the spark plugs and compression.

A bad ecm, can be shipped out for repair and then, it will be plug/play, no programming or key matching required.
 

·
Registered
Joined
·
1,085 Posts
Lots of ecu get condemned and it’s not the problem. What exactly is the charge on your battery, using a multimeter, with the car turned off just sitting in your driveway?
 
1 - 3 of 3 Posts
Top