VW Beetle Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
2000 Beetle 2.0 jerking, running loud getting between 4k and 5k on the high way. Ihave no Idea what could be wrong with the car. The Fan switch was recently replaced and it was running great. Then yesterday it start to feel like it might be stuck in gear and jerking. At some points it feels like its being pulled back. On the high way it is getting up to 4k/5k . I have no idea what this could be any clue? Someone said to change the fuel filter, the pulgs and wires were done last year. I know this has happend before and I think it stoped after I change the collant flange mind you i have put 4 of those on this car. SOMEONE PLEASE HELP. Please also if you can respond to my email [email protected].
 

·
Super Moderator
Cup- 2k New Beetle GLS/ 'Chino- 13 Beetle 2.5
Joined
·
20,869 Posts
Welcome to the org:wave2:

To have us better serve you:
1. Fill in your user profile- help (one of us with tools/equipment) could be near you.

2.Allow us to help you here and not by your e-mail- All problems, and solutions posted here can not only help you, but others that might run into your same problem.

3.Is your Check Engine Light on? If so, get your beetle scanned for fault codes. AutoZone scans your car and will print out your trouble codes for free. These codes can help us fix you baby. Even if your CEL isn't on, you can have hidden codes lurking to your unaware.

We also have an org members facebook page, feel free to click the link in my signature to find it and join. The more resources, the better.

All the best to ya. Hope your fix is quick, cheap and easy:)
 

·
Yay Yellow
Joined
·
57 Posts
Jerking like misfiring or missing? Is the check engine light ever blinking? I know nothing about coolant flanges but my bug did something similar at higher highway speeds and it was a cracked coil. Good luck to you and your bug.
 

·
Registered
Joined
·
2,299 Posts
Sounds like a problem with the automatic transmission. Problems with the valve bodies are very common. Go to the "transmission talk" forum and search on "valve body."

Your transmission may be going into "limp mode" where it will be basically stuck in 3rd gear. This is indicated on the dash by the PRNDL display showing all gears selected instead of just one.
 
1 - 4 of 4 Posts
Top