VW Beetle Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I had to have my 2000 beetle 2.0 go through state inspection. The inspector told me that the abs and air bag light was not working. I had the system ran to check the codes, but no codes are being shown for the abs or airbag. Can someone tell me what to check?
 

·
Wife's 01 1.8T mechanic
Joined
·
629 Posts
Car off. Insert key. Turn to run, one notch before start. Does the ABS and air bag light illuminate? If not, you have found where to start your search. BTW, a regular scanner will NOT do ABS and air bag codes. You need a VW compatible scanner, or, VCDS. My bet? A previous owner removed the bulbs to hide the faults. I think you will find missing bulbs in your cluster, and when you replace them, they will light up (and stay lit).
 

·
Registered
Joined
·
2,545 Posts
abs/seat belt

Where are you getting the car inspected? In Texas they don't give a roots A$$ if you go off and kill yourself because of an abs light or seatbelt light on. They only care if your car is polluting the beautiful Texas skies :D , then You're in trouble my friend and it won't pass inspection.
 

·
Registered
Joined
·
2,545 Posts
seat airbag

The airbag issue will most likely be the seatbelt receiver latch since those are prone to failing in these beetles, mine failed also. You gonna need a vag-com code reader to troubleshoot and reset that code. The ABS issue I would look at the fuse box on top of the battery since two of the green fuses to the right are for the abs system I believe. You also would need to use the vag-com to troubleshoot that system. good luck man
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
ok now i have another problem alone with the abs and airbag. I took the cluster out to check the bulbs, but they are no way to change bulbs that i know of. I put the cluster back in and now the car will not run. It will start in then just sound like it is bogging out than shuts off. I also found a wire under the driver seat that is not connected up. Does any one know what that does to? I am tring to attach photos ask a pic of the cluster when i turn the key on.
 

Attachments

·
Wife's 01 1.8T mechanic
Joined
·
629 Posts
That connector is for the seat belt warning, driver's side. The air bag connectors are yellow.

Not sure about the no start. I would disconnect the battery for a few minutes, then try again.

There has got to be a how-to on the bulbs out there. Search here, TDIClub, and the VWVortex forums.
 

·
Wife's 01 1.8T mechanic
Joined
·
629 Posts
Here's where your bag and ABS lights should be:

https://www.youtube.com/watch?v=5c4SRoVdojU

Interestingly, this video is about exactly opposite your problem. He's trying to disable those lights. It might be worth picking up a cable and VCDS software to check things out. It's really worth it if you do your own work. I have it on my laptop. You can do lots of things with it. For example, the warning bongs/dings are disabled on my wife's cluster.
 

·
Registered
Joined
·
2,545 Posts
vag-com

Here's where your bag and ABS lights should be:

https://www.youtube.com/watch?v=5c4SRoVdojU

Interestingly, this video is about exactly opposite your problem. He's trying to disable those lights. It might be worth picking up a cable and VCDS software to check things out. It's really worth it if you do your own work. I have it on my laptop. You can do lots of things with it. For example, the warning bongs/dings are disabled on my wife's cluster.
People just don't read these posting sometimes. I told him that 2-3 posting before that he needed a vag-com or aka vcds software to properly troubleshoot He's issues....and no there are no bulbs like the old days it's one big electronic cluster and LEDS behind it. You almost have to replace the whole cluster panel if one light go's out......He probably won't read this one either. LOL:p
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #12 ·
i tried disconnecting the battery and the car will still start then shut off. This did not happen until i removed the cluster, Any ideas
 

·
Registered
Joined
·
2,301 Posts
It is produced by Ross-Tech:

Ross-Tech: Products

I have VCDS-Lite and bought a OBDII-USB cable on ebay for less than $15. You probably will never need the full VCDS if you are just working on your own car.
 

·
:)
Joined
·
837 Posts
i tried disconnecting the battery and the car will still start then shut off. This did not happen until i removed the cluster, Any ideas
sounds like something is disconnected still in the cluster, or loose that is not detecting the microchip in your key
 
1 - 18 of 18 Posts
Top