VW Beetle Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
New member here so please forgive me...not familiar with the auto's in these cars but i picked the car up cheap hoping to flip it, has 129K miles on it...Have had it a couple weeks and have been fixing a couple things on it. Lately the trans has been shifting hard into 3rd gear and kind of shifting a little late into 3rd too. So I got some Valvoline import trans fluid and a filter and replaced it. I DO have a vag com and the trans was over 90 degrees C so i just let a little fluid run out of the check plug. Went to go drive it, thought it felt alright, soon enough still shifted hard..also slams into reverse kind of also, and slow to go into drive from reverse. It had problems with draining the battery from the cooling fans on so i fixed that but since then the battery is kinda junk. So i found out about the thottle body adaptation and thought id do that since its been ran dead before, was doing the adaptation and it said error, went to check codes i had some so i cleared them and did it again and went to go drive it and it shifted great, and pretty much as soon as the cold light goes of it starts shifting into third bad again....and then it starts revving a little before shifting into third..UGH!! Do i need to get this trans rebuilt or what?
 

·
Super Moderator
Joined
·
14,834 Posts
Not sure what you have, but it is not a 2001 Turbo S. :eek:


The Turbo S arrived for 2002, and every single one has the 6-speed manual. No automatics.

You probably have that troublesome automatic, that I would never buy. :(
 

·
5/23/10 <3
Joined
·
11,417 Posts
Probably a turbo sport, which is different from the Turbo S.

I would look into the valve body. Known problem components on these autos.
 
1 - 4 of 4 Posts
Top