VW Beetle Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 · (Edited)
Thanks for the add! I am a long time Volkswagon owner but just recently bought my first 2002 Beetle (Lilly) for my daughter! She is in great condition for her age and miles (150,000) but has an issue I am struggling to resolve. I keep blowing the NR 5 fuse and get that annoying irking brake alarm and indication. I replaced the parking brake switch and no avail. I then replaced the resistor pack for the blower fan, popped in a new fuse and all was good. Brake indicator light when out alarm silenced and EPC light went out. This afternoon on my way home from work (driving the car till I get it sound for her) shortly after I turned the ac on the fuse blew again and back to alarms. The blower fan continued to work in all speeds but of course the cruise control did not. Has anybody the same issue with a good fix? I read a couple of threads about the ac pressure but hesitant to just keep parts changing here. I rather find and correct the problem.
Thank You!
Jason
 

·
Super Moderator
Joined
·
5,367 Posts
Welcome to the org! Which brake alarm are you talking about, where it says your parking brake is still on when you're trying to drive? Has the AC been what was causing the fuse to be in the past? When the fuse isn't blown does your cruise work or is it always out? I'm sure somebody else will come a long and we'll be able to help you get these issues figured out.
 
1 - 2 of 2 Posts
Top