NewBeetle.org Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2005 vw new beetle, Recently it started to have problems and is going into limp home mode. The engine runs great, the transmission runs great but every once in awhile when i start it i'll get the [P][R][N][D] brackets on the bezel with the ses light coming on. It seems to be stuck in 1st or 2nd with no reverse. 0ther times ill get in and it'll run fine and get me where i need to go. There is no lurching, odd noises or anything. My father took it to an import mechanic and he tried cleaning a sensor on the trans but im not sure which one as i was not there. The issue still continues and they're now trying to convince me i need a complete transmission overhaul. But as i said, some of the time it runs like a charm, this issue only happens when i first start it up if it does happen and doesnt go away til i shut it off again. It's the diesel bug also btw. Can someone please help me??
 

·
Registered
Joined
·
793 Posts
The 2005 TDI should have the DSG transmission, but feel free to send over a PM or email with your VIN if you would like confirmation.

The DSG transmission has had some issues and some models currently have a extended warranty directly from VW. The fluid / filter should be changed every 40k miles according to VW, but we have customers that change out every 20k.

I would probably start by checking with the dealer to see if there are any open campaigns for your car. The dealer may be able to warranty the transmission or mechatronics unit if it is going bad.
 
1 - 2 of 2 Posts
Top