NewBeetle.org Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I just turned one CEL code into 10!

The car was throwing the CEL code 1128 (System too Lean). Reading the forums, I attempted to clean the MAF sensor which didn't help and actually made the car run sluggish. I replaced it with a MAF from Auto Zone instead of a stock Bosch unit to save a few $ and also replaced the Fuel Pump Relay (which seemed to help in correcting another person's problem). I cleared the code and the car runs better but the CEL came back on after a day and a half throwing the following TEN codes:
P0171 - System too lean
P1225, P1227, P1226, P1228 - Fuel Injection Circuit short to ground (cyl 1-4)
P1451 - Sec Air Inj System Pump relay short to ground
P1421 - Sec Air Inj Valve Circuit short to ground
P1425 - Fuel Tank Vent Valve Circuit short to ground
P1472 - Evap System Leak Detection short to ground
P0440 Evap Emission Control System Malfunction

Besides opening up a can of worms, can this issue be caused from replacing the MAF with an aftermarket unit or can it possibly be from replacing the stock relay with the upgraded one? Instead of replacing the #409 relay with the same one, a different one was substituted. Can't remember the # and my daughter is driving the car. Can anyone point me in the right direction as to which vacuum hoses contribute to the car running lean?

Thanks in advance for any and all help- Mike
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
***Update***

The original relay I removed from the car was #167. I don't know if this is one that was installed from VW on the line because when I google the numbers, it's typically associated with other models, none listed Beetle. (We bought the car used) It did only have 4 prongs. I did pick up what is listed by VW, the #409 relay and installed that and a Bosch MAF today while resetting the code. After the car originally showed the 10 codes several weeks ago, when I placed the scanner on the car today, it only showed the P0171 (Too Lean) We'll keep you updated and see if the codes return.
 

·
Registered
Joined
·
5 Posts
Do you still check in on this old post? Did you every resolve this problem since I am having similiar problem. My 98 beetle was one of the first, got it first week the bugs were available. Just looked at replacing my fuel pump relay and found it also has the 167 which is factory original. Checking, the 167 is a fuel pump relay for at least the 1997 passat. It is so different from the #409.
 

·
Registered
Joined
·
2,172 Posts
It looks like at least some of the '98 beetles came with the 167 fuel pump relay which is a carryover from the earlier generation. The '98s have a few other things that carry over from Mark 3 as well.

The list of codes above except for P0171 is typical of a bad fuel pump relay. I would try a new 167 relay and see if that solves the problem.
 
1 - 6 of 6 Posts
Top