NewBeetle.org Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I bought my 98 beetle new. It has 93000 mi and had only minor problems. Then about a year ago the trans starting slipping in 1st but only when cold. AAmco told me they would not rebuild only replace. A VW Audi specialist told me they won't rebuild any 98 trans, only replace. The dealer I bought it from said the exact same thing. I didn't want to invest the $3500+++ into the car, but I really like my bug. I was lucky to hear about another VW Audi specialist in North Branch, NJ. Dan's Auto Repair. Dan told me he would just drain the trans, check for debris, and fill it. No flush. The car is running great. It's only been a month but it feels good. Just goes to show that there's still people that will try the simple fix first before hitting your wallet.
 

·
Certified Arcade Tech
Joined
·
416 Posts
Sadly I have not heard ANYTHING good about Aamco. I guess back in the day they used to be a decent transmission rebuild/repair shop? But as of late? Seem to be more of a "Dealership" 'we don't repair we replace' direct swap shop.

We have a local transmission shop just north of Syracuse that appears to be an actual decent repair shop that doesn't charge 4 arms and 8 legs for service.

I've taken my own suv/mini truck there for just a free 'transcheck' and I already knew exactly what the problems where. They pegged it correctly and even traced back an engine problem that I missed.

Glad to read it's worked out! Sometimes it's a simple thing...other times it's a headache. Glad it was a simple one!

S-
 
1 - 2 of 2 Posts
Top