NewBeetle.org Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi guys im new here and my friend has a 99 beetle and her heated seats, outside temp and her day time running lights arent working anymore. Im thinking its just a fuse? but the only fuse's ive found so far are the ones mounted on top of the battery and there all good.

Any idea what would cause this?

Thanks for your help Greg?
 

·
Registered
Joined
·
11,588 Posts
This should help; there is another fuse box, when you open the drivers side door, there is a fuse box to the left of the speedo. A dime or penny will open the door and the fuses will be in there.... download this .pdf for the locations of the different fuses and what they are for. There are also relays for the head lights under the dash; that could be possible as well...

http://www.justanswer.com/uploads/deleontow/2009-08-07_041633_98_Beetle_Fuse_arraignment.pdf
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3 (Edited)
Thanks for the quick reply. I downloaded the pdf file but the location of the fuse panels are really vague. I found the first one next to the driver side door, but i cant seem to find the other one. In the pdf file they say its behind the instrument cluster to the left? Am i suppose to remove the speedo cluster in order to find it?

Thanks Greg
 

·
Premium Member
Joined
·
4,753 Posts
Not the panel he's trying to locate, he found that one.

The panel is to the right of the OBDII port, and is behind the trim panel below the steering wheel, the trim panel has to be removed to access, as far as anyone I have spoken to has been able to figure.

There is a DIY or How-to somewhere that shows how to dismantle the entire dash, which will cover the R&R of this panel. I'd have to dig for it, perhaps someone has it.

MORAV
 
1 - 5 of 5 Posts
Top