NewBeetle.org Forums banner

1 - 11 of 11 Posts

·
Peace Love & T.o.D.
Joined
·
2,802 Posts
Have you changed your cabin filter.
That is usually the culprit.
 

·
Premium Member
Joined
·
4,753 Posts
I am assuming you are referring to the evaporator. This is a significant project which will involve dismantling a portion of the dash. There is a good DIY or How-to somewhere on the Org. Possibly I can find it and if so will put it up. Here is the Heater & Evaporator D&A

I wonder however, if you have "pollen" filter on your model and if this is the issue. The evaporator should only become an issue if the condensation drain(s) are plugged up, and mildew or mold forms.

MORAV
 

Attachments

·
Super Moderator
Joined
·
14,714 Posts
Can someone link that thread with the blow-by-blow pics of how to change the cabin filter?
 

·
Premium Member
Joined
·
4,753 Posts
Maybe the cabin filter, but as this is before the moisture is extracted from the air to be cooled, the more likely source is the evaporator. From the Bentley -
 

Attachments

·
Dubbed Spiderman
Joined
·
2,830 Posts

·
Super Moderator
Joined
·
14,714 Posts
Thank you for the link. I tore into it today. :p
 

·
Registered
Joined
·
79 Posts
I took mine apart last night and it looks like it hadnt been replaced in FOREVER. Also, the panel that you remove right before you gain access to the filter has a pad on the underside of it. Can you replace that piece? Since mine seems to be falling apart.

-Agent P.
 

·
Premium Member
Joined
·
4,753 Posts
Probably had never been replaced ;)

Anything in a Bug is replaceable.

Let us know if your odor thing improves.

M.
 

·
Super Moderator
Joined
·
14,714 Posts
I took mine apart last night and it looks like it hadnt been replaced in FOREVER. Also, the panel that you remove right before you gain access to the filter has a pad on the underside of it. Can you replace that piece? Since mine seems to be falling apart.

-Agent P.
I know what you are talking about. I thought the same thing about replacing, but the one in my car was still "glued" down. So, I just shook it out, and put it back in.


Oh, I want to add.....I broke a few fingernails :( doing that. *But* I had all the tools, *and* I put the dash back together - and NO SCREWS LEFTOVER! :bigthumb:
 

·
Premium Member
Joined
·
4,753 Posts
and NO SCREWS LEFTOVER! :bigthumb:
You mean you are supposed to use ALL the screws putting things back together...
:roflmao:
Imagine that concept! Unheard of, for many!
 
1 - 11 of 11 Posts
Top