VW Beetle Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey everyone,

I have a 2002 Beetle 2.0L. Recently it didn't start out of the blue (drove to the mall everything was fine, came back out, nothing happened when I turned the key just dashboard lights came on). So I got a jump and drove home. On the way home the battery light came on, then the ABS and airbag light, dashboard lights turned off, then back on. Indicators got stuck at random numbers.
Tried to start the car 2 hours later, nothing again. Two weeks later (today), I finally made an appointment to get a new battery. Jumped the car, let it sit for a while to let it charge, it died. Jumped it again and tried to drive to the garage, all lights came on again, I hit 50mph (at least I think cause the dashboard was stuck on 60), car starts beeping and feels like the engine is going to die any second. I pull over, turn it off, doesn't turn back on again.

Any idea what could be wrong? I read before that it the battery, hence why I was going to replace it, or the alternator, now I read that it could be all sorts of random issues. Has anyone experienced this and found a solution? I'm really tight on money and would rather not have to spend it on a new battery and alternator and whatever else could potentially be the problem.

Thanks!
 

·
5/23/10 <3
Joined
·
11,417 Posts
Have you had the battery tested? The fact that you can get a jump and get going again indicates something with the charging system. But a dying battery can certainly lead to some issues like you describe.
 

·
Registered
Joined
·
15,842 Posts
Sounds like you have a charging problem; I would charge the battery and drive to a auto parts store, have them test your whole charging system. If you have a new battery and it is dying; the charging system is most likely the issue. Having a friend; follow you to the store with jumper cables or a jump box, might be a good idea and that way, you do not get stranded somewhere.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Thanks for the suggestions! I ended up buying a new battery from Walmart today, installed it, cleaned the connections in the process because they looked corroded and it drives again! All lights turned off (even the check engine light which has been on for 3 months) except for the battery light.

I am assuming I need to get my alternator checked as well, car drove fine when I took it for a quick spin and I'll take it on a longer drive later.
 

·
Registered
Joined
·
15,842 Posts
Just go to any auto parts store; like Autozone or o'reilly's and they can test the whole charging system on the car for free. Better safe; than sorry and you can confirm, everything is working as it should.


Sent from AutoGuide.com Free App
 
1 - 5 of 5 Posts
Top