VW Beetle Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
220 Posts
Discussion Starter · #1 ·
my airbag light has just come on and it has not turned off my car is a 2002. I am woundering what the warranty on the airbag is as i have just passed the 50k mark and if this has happend to anyone else? any insight would be great.I have a 2002 1.8t


thanks for any help.
 

·
a.k.a. porkchopzz4
Joined
·
890 Posts
As far as I know, the airbag is only covered under the 2 year bumper to bumper warranty.

My airbag light was on for some time and when I finally got around to scanning it with my VAG-COM, it had a code about an instrument cluster malfunction. I erased the code and the light has not come back on since (it has been about 6 months since I erased the code). So perhaps it is just a one time glitch?

Others have had the connector under the seat come loose - I would check that first.
 

·
Registered
Joined
·
48 Posts
Our 2004 had the airbag light come on at about six months. They did the code erase thing and it soon returned, so they kept it a day and fixed it under warranty. Didn't care what they did as long as they fixed it, but I seem to recall something about a bad sensor.

Not having an explosive device aimed at my face is one of the reasons I prefer my bike.
 

·
Registered
Joined
·
7 Posts
mark said:
my airbag light has just come on and it has not turned off my car is a 2002. I am woundering what the warranty on the airbag is as i have just passed the 50k mark and if this has happend to anyone else? any insight would be great.I have a 2002 1.8t


thanks for any help.
Hi, I recently purchased a 2002 Snap Orange (Auto) Beetle with 65K on the Odo. I have a similar problem (maybe) to yours. The Seat Belt/Airbag light recently just came on and stayed on. I took it to the local VW dealer and found that the Drivers side Seatbelt buckle is at fault. Apparantly there is a sensor in the buckle that's shot. VW says it will cost $230 to replace the Seatbelt buckle assembly. I was wondering if there was a way to disable the sensor in this assembly or is buying the new unit the only way to remedy this problem???
 
1 - 4 of 4 Posts
Top