VW Beetle Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I've just replaced a tail light and blinker. The taillight was completely out. Blinker was working before replacement but was doing the double time flashing indicating that it was going to go out shortly. So, replaced.

Now all lights are working including hazards. All flash when I put hazards on. But, the blinkers don't work when I press the turn signal.

I checked the fuses. All good.

I only changed one side. Could this be the problem?

I've seen some say it's the ground, but how do I fix that?

Thanks!
 

·
Registered
Joined
·
15,841 Posts
Typical problems usually narrow down to the flasher relay (most common), bad bulbs/socket or the turn signal lever assembly is worn out or has bad internal connection problems. I recently had a similar issue and in my case, it was a bad bulb sockets (loose, damage from heat/age; causing connection problems) and a failing flasher relay.
 

·
Registered
Joined
·
415 Posts
Typical problems usually narrow down to the flasher relay (most common), bad bulbs/socket or the turn signal lever assembly is worn out or has bad internal connection problems. I recently had a similar issue and in my case, it was a bad bulb sockets (loose, damage from heat/age; causing connection problems) and a failing flasher relay.
I've been through the relay and a bad socket. Swap the bulb from the working side to the non-working side, then repeat with the socket. That will help with socket diagnosis.
 
1 - 3 of 3 Posts
Top