NewBeetle.org Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
On Christmas Eve, I stopped at the grocery store to get some supplies before going home. After I returned to my Beetle, I started it, only to have it die after a few seconds. I was puzzled but turned the key again. Same thing. And then the same thing again. Finally, on the fourth try, my car started up and stayed running, but I noticed the odometer had suddenly reset itself to zero and the check engine light and the airbag light had come on. They haven't shut off since then. What's going on here? Would I be right in guessing that it is something electronic? :confused:
 

·
20V GTRS
Joined
·
1,120 Posts
It is defintly electrical. Try the basic stuff first and check your battery connections and make sure they are good and tight as well as make sure the terminals are clean. If it is a servicable batery, check the fluid levels and top off as needed. If you still have warranty, use it. If not, as a safeguard you may also want to stop by a AutoZone or another store like that and have the battery load tested. If all that is fine and it happens again I would have the charging system checked. If all is still well and it keeps happening then there is a short or a bad componet somwhere.
 

·
Eine Kleine Panzer
Joined
·
210 Posts
If the car is running sluggish and the exhaust smells like rotten eggs, your coil packs are bad.

Do you have all of the other electrics (washers, lights, turn sigs, blower fan)?
 
1 - 3 of 3 Posts
Top