VW Beetle Forum banner

21 - 28 of 28 Posts

·
Registered
Joined
·
168 Posts
i too have had the same problem. i'm pretty sure mine's electrical though. one time it was on and when i went over some railroad tracks it turned off. Further down the road i encountered more tracks and it turned back on. so i assume this is some sort of short. though, it does take a good while for it to turn off during the winter months...i'd replace the sensor just to be safe. i'll do the same :)
 

·
Premium Member
Joined
·
838 Posts
I would change it. I kinda ignored it on Rodney...and the period of flashing blue got longer and longer...until one day, it was red and alarming on a roadtrip.

Its a simple, cheap fix, and the peace of mind alone is well worth the sum.
 

·
Premium Member
Joined
·
686 Posts
Mine started blinking red for the first time today in my '03. I need to add some coolant. I was told that it is important to get the coolant from your dealer only in order to not destroy the water pump. Is this true? By the way, I never had my blue light blink.
 

·
ElectricHarleyHouseOfLove
Joined
·
1,751 Posts
Yeah, that's true. You'll want to get the G12 from the Dealer (or you can order this kind online, but if you're low, i'd just get the stuff locally) .. Don't wanna use the regular green stuff!


On a side note, i think my blue light problem finally got solved. I replaced the coolant temp sensor and it still did its thing, so i was planning on doing the thermostat, too.. well, my coolant flange (the part that holds the temp sensor) started leaking, so I had to replace that first. When I was on my way for a coolant flush\fill after that, my tranny died. Since I got it back from being fixed, the light no longer comes on randomly, so I'm guessing some kind of error code had to be cleared out after replacing the sensor. woo!
 

·
Premium Member
Joined
·
686 Posts
Yeah, that's true. You'll want to get the G12 from the Dealer (or you can order this kind online, but if you're low, i'd just get the stuff locally) .. Don't wanna use the regular green stuff!


On a side note, i think my blue light problem finally got solved. I replaced the coolant temp sensor and it still did its thing, so i was planning on doing the thermostat, too.. well, my coolant flange (the part that holds the temp sensor) started leaking, so I had to replace that first. When I was on my way for a coolant flush\fill after that, my tranny died. Since I got it back from being fixed, the light no longer comes on randomly, so I'm guessing some kind of error code had to be cleared out after replacing the sensor. woo!
Thanks. I'll get some coolant at the dealership.
 

·
Registered
Joined
·
1 Posts
Blue/Red coolant light

I just bought an '03 two weeks ago. I noticed the blue light on my car too. It would go off after driving for a few minutes. However, the other morning, when I started my car, the light is now RED and it beeps. It also flashes and after awhile it turns blue and then goes off. Last night however, the RED light came on again and flashed for a few minutes and went off again. My car didn't come with an Owner's Manual so I'm glad that I found this site. Can anyone tell me what I need to do to get the RED light to stop coming on? Do I need to fill the coolant?? I haven't been driving it because I don't want to ruin anything. Thanks!
 

·
Y2K Speedle
Joined
·
1,089 Posts
Check coolant level and ad if necessary ( G12 only and distilled water - 50/50 mix )!
Never drive with red lights flashing and car beeping!
Might be water pump or a leak in cooling system. Is there a puddle under the car? Are you dye timing belt replacement ( 120000km). This is the time of the year when week coolant hoses will burst ( outside temperature drop ).

Good luck
 

·
Registered
Joined
·
1 Posts
2001 New Beetle 2.0, 30k miles, I've only had it a couple of months.

Since I bought it, the blue coolant warning light has come on at startup, then eventually has turned off. Having read this and other forums I believe this is normal enough behaviour.

However, it seems recently that the time to turn off has been longer and longer, and today for the first time after about 15 minutes of stop/go traffic the light started blinking blue.

Uh oh. Kept driving to my destination planning to get coolant etc etc but then after about five mins it goes out again. Phew (I hope). Popped the hood after I parked and the coolant tank looks very full (hard to see the marks tho) but that's probably because the engine was still warm.

Coolant is nice and red so it looks like the previous owner used the good stuff.

The only other problem experienced with this car is that on 2 occassionas it has required 2 or 3 goes to start. Normally perfect.

Other info; I'm currently getting about 320 miles per tank.

QUESTION: Have I a problem with the coolant itself, the tank, the sensor? What does the flashing blue light really mean?

Help appreciated.
Hi, just bought my daughter the same vehicle and we're having the same issue with the blue light. I'm at the shop as I text...it's the temperature sensor. Very easy fix. We've been here all of 12 minutes and the parts off and the new ones just about on. We got it at Auto zone for $17.99 even though the on line add says 14.99. Still a good deal. Well the parts on and the diagnostic says 0000, now we're gonna start it up and see if the check engine light goes off........SUCCESS. So go get your temperature sensor changed. PEACE.
 
21 - 28 of 28 Posts
Top