NewBeetle.org Forums banner

1 - 7 of 7 Posts

·
New NB Owner/Lover!
Joined
·
251 Posts
Discussion Starter #1
I had my CEL come on for the first time ever last week... it happened after sitting in the car with it idling for 15-20mins (I was wasting time on lunch break). Car drove and sounded fine... I checked the code when I got home and it said:

P0411 Secondary air injection (AIR) system incorrect flow detected

then something about RPMs too low at idle... sat and let it idle and the RPMs were fine... I assume it's some emissions thing I don't need? Anyway, so after unplugging the scanner the light went away and all was fine until yesterday when I was sitting in it again for 15-20 solid minutes... light came back on, and hasn't gone away since. This morning I got in and headed to work and I got the gas cap light. I haven't gotten gas since yesterday morning so I found it odd for it to come on now... got out, tightened it and started the car a couple of times. It's still on! :confused::mad:

I also noticed a "thumping" noise coming from the rear when stopping at a light/etc (sounds like something rolling around in the trunk and hitting) but there's nothing back there... I'm pretty much at a loss right now as to what's going on. My warranty just went up not too long ago, so this is quite unsettling. Any ideas?
 

·
HP Technician
Joined
·
449 Posts
Fill up to the brim with some good gas and drive it a day or so and see if it corrects itself. Might be some bad gas or some crud in the tank from that bad gas.

I've gotten some crappy cheap gas from a station 'next to a swamp' and problems didn't appear till few days later.

I've also gotten some problems by going several trips to the station without filling up. I think water and other issues arise when just getting partial tanks time and time again.

Now I simply run till empty and fill up all the way on top of ignoring gas prices and always going to the same quality Chevron station right next to the Interstate and have had no issues since. Going to a quality interstate station means gas never sits in the tanks at the station long - it's constantly being refilled.

That Chevron is the most expensive of any of the interstate stations by my house (and I need premium) but I just quit concerning myself over it. Running trouble free is more important to me than saving $1 a fill up.
 

·
New NB Owner/Lover!
Joined
·
251 Posts
Discussion Starter #3
so you think it may just be something icky in my fuel lines/etc? sounds like a decent suggestion since I've never had any issues with anything before... the thumping is weird but it only does it intermittently when i stop. i've had cars with weird fuel pumps before and similar noises... we'll see.
 

·
I'm not a dude.
Joined
·
1,230 Posts
Well it's when sitting completely still... which is odd.
I think I know what noise you are talking about.. Sounds like it is coming from the rear passenger side. I only hear it if I'm sitting it the car shortly after I shut it down. I don't notice it while the car is running, probably because my exhaust is a little too loud to hear it. I thought it had something to do with the gas tank because it sounds like the noise it makes when putting gas in the car. I don't know if you've ever had someone else pump the gas while you're sitting in the car though.
 

·
Registered
Joined
·
448 Posts
Mines is doing this as well. Did you figure out what the exact issue was? Started with the gas cap light coming on early this week and now a check engine light. Car drives normal and I'm starting to hear a thumping noise from the trunk. Any suggestions?
 
1 - 7 of 7 Posts
Top