VW Beetle Forum banner
1 - 11 of 11 Posts

·
MegaWatt
Joined
·
32 Posts
Discussion Starter · #1 ·
You'd think I'd be happy my CEL never comes on, but I'd sure like for it to when there's a problem! It's a 2000 1.9 TDI, but the problem is not car specific. I bought the car 4 years ago on Ebay, and I've been simply restoring it to its former glory ever since. I have VCDS, and I've had/still have things needing fixed, but the main one was the turbo was shot. But no CEL. Replaced the turbo, N75, vacuum pump, etc, etc., until I got the turbo up and going. YAY! But never once has the CEL come on. I originally suspected the crook that sold me the car in the first place might have pulled the CEL out so I wouldn't know there were problems, but I think I'm seeing online that it's a LED? Hmmm. Anyone have ideas why my CEL might be on a permanent outage? Thanks for your help!
 

·
Registered
Joined
·
15,902 Posts
Well, one way to see if the CEL works; is to use VCDS to do a series of "output tests" on the speedo cluster. It will turn on each of the lights in the speedo cluster.

Here is a video; showing this process and which light come on and off (this is also; an excellent way of testing your gauges if they are not working).

https://www.youtube.com/watch?v=5c4SRoVdojU

https://www.youtube.com/watch?v=I3--GvnKE10

Ross-Tech: VAG-COM Tour: Output Tests

If all the lights work; then you are ok, otherwise the light bulb in the speedo cluster would need to be replaced or the cluster needs to be repaired?

To do this procedure in VCDS: you would:

1. select: control module: click on "select"
2. select: #17 instruments
3. selectL #3 output tests
4. then there is a guided series of tests; that activate different aspects of the speedo cluster, including the "CEL"
 

·
Registered
Joined
·
3,690 Posts
SES/CEL/MIL should light up when the ignition is turned on and the cluster is in "Bulb Check". Same holds truck for ABS, Airbag and other lights. This is something State Inspectors are trained to look for and supposed to check during Emission Inspections.

If the bulb does not light it is likely been disabled somehow. Either something is covering the bulb behind the cluster face or someone cut the bulb out or damaged a circuit trace to the bulb.
 

·
Super Moderator
Joined
·
5,367 Posts
SES/CEL/MIL should light up when the ignition is turned on and the cluster is in "Bulb Check". Same holds truck for ABS, Airbag and other lights. This is something State Inspectors are trained to look for and supposed to check during Emission Inspections.

If the bulb does not light it is likely been disabled somehow. Either something is covering the bulb behind the cluster face or someone cut the bulb out or damaged a circuit trace to the bulb.
This...if the LED is working then it should come on at this point. It's entirely possible that it's dead, but I find that highly unlikely since it's generally only on at this time..and well if the car is busted.
 

·
MegaWatt
Joined
·
32 Posts
Discussion Starter · #6 ·
Update

When I turn the key on, I'm not getting a CEL during the bulb check. Or cruise control. Or glow plugs. And one or two others. So I took out the cluster and disassembled it. Obviously someone's been there before - there was electrical tape across the glow plug LED. Probably because the glow plug circuit relay had been bad and someone didn't want to fix it before they sold it to me. I also checked the LEDs that weren't working with a 3v power supply. About half worked, and the rest didn't. Including the CEL light. So I'm contemplating sending it out for repair. Best to let an expert fix her up, especially if I get a lifetime warranty with it. And it shouldn't need reprogramming when I get it back. Thanks to everyone for your input!
 

·
Registered
Joined
·
15,902 Posts
Cool, well let us know; where you send it out for repair and how the repair goes. This issue; is becoming more and more common! So, we need as much feedback as possible; on vendors and repair experiences for speedo clusters. Keep us informed; so, others can learn from your experience in the future.
 

·
MegaWatt
Joined
·
32 Posts
Discussion Starter · #9 ·
Great Instrument Cluster Repair Service!!

OK, I'm reporting back. I sent my instrument cluster to BBA Remanufacturing, Inc. in Taunton, MA, and they did a great job in amazingly short time! The cost was $244.99. They sent me a UPS label to ship it to them, and they repaired it in 1 day and shipped it back to me. It was out of the car for only 8 days. They repaired the LEDs that didn't work and I learned I have more electrical work to do. The seat belt light tells me I need to fix that circuit, and I have known there was an issue with the glow plug circuit. Now the CEL tells me to get busy and fix it!! The nice thing is that since it is the instrument cluster that came out of the car, I didn't have to have anything reprogrammed when I reinstalled it, and the odometer mileage didn't change. Lifetime warranty, too. Another thing - if they can't repair your cluster, they send it back and give you a complete refund! I highly recommend BBA Remanufacturing. They even send a link so you can track the status of your repair while in the shop. I found them on Ebay. Do a search for "Volkswagen Beetle Instrument Cluster Repair Service". These are great folks!
 

·
Registered
Joined
·
15,902 Posts
randywharton, I'm glad that BBA Remanufacturing; ended up working out for you. After going through the whole; reprogramming and soft coding process, I believe that repairing a speedo cluster is the most cost effective and hassle free way to go. The lifetime warranty; is a great reassurance, that if anything else ever happens, they will fix it. Some other members; ended up having their speedos sent back, as not repairable (I am glad; that wasn't the case for you). The more people's repair experiences we hear about; the more we can direct others, where to get their own speedos repaired as well. This problem; is only going to get worse, as time goes on. :)

Please post up any codes; that you have and we will do our best, to help with the rest of the issues. :jumpy:
 
1 - 11 of 11 Posts
Top