NewBeetle.org Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter #1
2003 NBC with 6K on the ODO and the Check Engine light has come on and stayed during the past couple of days. I have checked the engine for loose wires, checked the emissions stuff as much as I can, checked the gas cap and found nothing wrong. I plan to take her in on Monday, but b4 that, any ideas on what could be going on? Thanks and have a great Christmas.
 

·
Super Moderator
Joined
·
14,766 Posts
I took my 2002 in. The CEL was on, immediately after getting gas. I didn't worry too much. The loose gas cap had happened before. But, after two more fill-ups, and same old CEL, I took it in. My fuel line is clogged. From bad gas.

I could pay $300 for them to unclog, ~or~ buy a couple o' cans of what she called "Drano": 44K, Power Enhancer, Rapidly Removes Harmful Engine Deposits.

I have given my engine one treatment, light still on. But, I have one more to go. I had to wait for the "low gas" light/beep to go off, then put this stuff in the tank. I was told to then: "Kinda drive the car hard". And, stay away from Texaco and Arco (of course, the two stations I use).

In the winter, I guess the gas companies put some kind of additive, that clog our fuel lines. Union 76, and Chevron are the best, she said. So, we are trying the 44K, and better fuel. And crossing our fingers that this clears up.

The car runs fine. That light is driving me crazy, though.

Good luck to you!
 

·
Registered
Joined
·
11 Posts
Engine light

I had my CEL come on,,,, changed the air filter and it went out in a couple of miles,,,,,have 62,000 miles,,,
 

·
Registered
Joined
·
762 Posts
No way to tell why the MIL is on. There is a chance that there are no faults with the engine, but rather another control module is hurting and asked for the MIL to be turned on (TCM and instrument cluster can do this).

Without any fault codes, we can all toss random guess out at best. I say replace the engine speed sensor.:p

Post up what the fault are and I'll spill the beans as best I can. Have you though of getting a KEY-USB from Ross Tech? You would then be able to see what the faults are yourself.
 

·
MyBug53
Joined
·
4 Posts
check engine light....

:confused: I see this is a problem for many folks.
We bought our 2000 lime green baby last week. Had it checked out at Firestone first, checked out fine even with 117000 miles.

First gas fill and the next morning we notice the CEL is on. Arrgghhh. We've tightened gas cap and will wait a fill or two.
Other folks having htis problem????

:confused:
 

·
Super Moderator
Joined
·
14,766 Posts
First, Welcome to the Org, 53! :wave2:

Also, your "lime green" is officially called "Cyber Green". :D Cool, huh? ;)

To follow up on my CEL from my above post, after two cans of the $20+ 44K cleaner, my CEL was still on. So, back in I go.

As it turned out, the $20+ per can 44K worked! My fuel lines were good! By coincidence, the light was still on because of the O2 sensor. Covered under warranty, at the time. (No longer in warranty. :( )

And, yes, if the cap is not tight, it will trigger a CEL. Happened to me a few times. *BUT* not the time I left the self-serve pump with the cap off, and fuel door open! Go figure! :rolleyes:

Make sure you use quality fuel. And the correct grade. Yes, it makes a difference. ;)



Good luck to all my CEL friends! :lol:
 
1 - 7 of 7 Posts
Top