NewBeetle.org Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter #1
I would like to run something by you guys....
My project 2002 1.8T had a code that told me that either the pedal sensor or throttle position sensor was bad. It turns out that I couldn't clear the code no matter what and I ended up trying an ECU (of the same part number) out of a boneyard.
I put the new ECU in and the code was gone. Now the dash is flashing the electronic immobilizer mode.
I called the stealership and they told me that the ECU code from the boneyard doesn't match the key and so everything needs to be reflashed with the same code. Since the car cannot move, I have to pay for the tow to the dealership and get it reflashed. I am looking at around $238 to reflash plus the tow.
Is this sounding correct? It seems insane, but I am new to the whole Beetle thing.
 

·
squirreljuice
Joined
·
388 Posts
I had the same problem. Turns out there was a grounding issue in my O2 sensor circuit and that fried the ecu. I highly reconnect making sure the wiring around your O2 sensors is still ok. But otherwise, that does sound about right. You could also have the car stage 1 tuned and that would come with immobilizer defeat (depending on the company). Stage one is a fun upgrade from stock, especially if you have the 150hp motor.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
79 Posts
Discussion Starter #3
OK, now it is getting strange....
I was going to have a local company flash both the key and ECU and he tells me that I also need the speedometer that the ECU came out of due to the codes in it?
This is the first time that I have heard this.
 

·
Registered
Joined
·
3,690 Posts
Yea the cluster has all the brains for these cars, it is a PITA.

As the other person mentioned, there is a stupid VW design where they got cheap and left out 1 ground wire for the O2 sensors and if something goes haywire it can cause the throttle pedal to not function correctly.

I think you can cheat and just put an additional ground on to repair the issue?? I will see if I can find the info and post a link.

Here is the link. Squirreljuice was the person who opened my eyes to this stupid design that will cause issues!

http://newbeetle.org/forums/1-8-liter-turbo/63058-throttle-doesnt-work.html#post863874
 
1 - 4 of 4 Posts
Top