NewBeetle.org Forums banner

1 - 9 of 9 Posts

·
Super Moderator
Joined
·
14,714 Posts
Discussion Starter #1
During my journey on Friday, I noticed that my turn signals weren't working. Stopped in the next town, and tested things, and discovered that I have no horn, no blinkers, no headlights, no fans. The cruise control on the turn signal stalk works, but not the blinkers. I can feel the heat and cool, but cannot use the fans. I have high beam usage, but no running or headlights. Nothing works with the wiper stalk.

Got to where I was going Friday evening. Small town, no VW dealer. My niece checked the former VW dealer, now selling only Mazdas, and they also service VWs still. She found out that they are also open on Saturday! :clap:

Took it in, only a few blocks from the motel. The had it most of Saturday. They could not fix it, with a skeleton crew, but zeroed in on those fuses not getting power for some reason. Oh, and by the way, Bernie Bishop Mazda of Brookings Oregon, charged me $0... :bowdown:

So, I drove home today, with no headlights, no blinkers, and no A/C for the 90 degree freeway drive. :eek:

Anyone have any ideas???? Help!
 

·
5/23/10 <3
Joined
·
10,919 Posts
Ignition switch would be my first guess.
 

·
Super Moderator
Joined
·
14,714 Posts
Discussion Starter #3
They did not mention ignition switch, but they did mention the headlight switch as possibly being the culprit.
 

·
big poster turned lurker.
Joined
·
9,487 Posts
Nope... the electrical part of the ignition switch is ALWAYS the culprit with those symptoms.

GermanAutoParts.com

Watch out though, it usually fries some of the wiring behind it too.

It's an easy swap to do, if you have the small and long screwdrivers needed to do the job.
 

·
Super Moderator
Joined
·
14,714 Posts
Discussion Starter #5
I will order that part, but do you really guarantee that it is the problem? I am no mechanic....... :(
 

·
big poster turned lurker.
Joined
·
9,487 Posts

·
Super Moderator
Joined
·
14,714 Posts
Discussion Starter #7
*takes a deep breath* He made that look relatively easy. Pray for me! :eek:
 

·
Super Moderator
Joined
·
14,714 Posts
Discussion Starter #8
OK. I ordered it. I only hope I can find someone to install it. :anon: I don't have those kind of tools.
 

·
Super Moderator
Joined
·
14,714 Posts
Discussion Starter #9
Thank you Smiley and Toad! I took it in, just said to install a new ignition switch, no diagnosis, just do it. They did, and yes, that did the trick. Thank you! I got lucky, too. Had a 2012 white CC for a loaner. O...M....G!

As I thought about it, it made sense. All of the things I did not have, were things that only work with the key on. Ding! Made perfect sense, and I learned something new. I may let the guys at Bernie Bishop Mazda know this. Not that they could have fixed on Saturday anyway.


A big Thank You! :heart:
 
1 - 9 of 9 Posts
Top