NewBeetle.org Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Red check oil icon flashes and sounds three times but only when I slow to 15MPH, never when I'm driving; oil level fine. That's happened the first time in the the last week but the slowing-blinking oil light and 3 beeps sequence now happening more regularly.

Related? Yesterday only the turn signal (left) blinking/sound was twice the speed normally; lasted only for about 3 minutes of intown driving and quit; hasn't repeated today (yet).

Anyone out there with a magic VW wand?

Joseph

2000 VW 2.0, 136k miles--and otherwise doing great.
 

·
Registered
Joined
·
13,860 Posts

·
Registered
Joined
·
120 Posts
low oil pressure most likely. My moms vw did something similar and the mechanic said it needed a pickup tube in the oil pan. I ran some seafoam in the oil and changed it twice within a 1000 miles. Ran a cheaper filter and synthetic oil but it did the trick. about a thousand miles later she cracked the oil pan pulling into a parking lot that had a huge hole in the ground. Mechanic replaced the pan and said the pickup tube looked good from the seafoam.
 

·
Registered
Joined
·
2,501 Posts
seafoam

low oil pressure most likely. My moms vw did something similar and the mechanic said it needed a pickup tube in the oil pan. I ran some seafoam in the oil and changed it twice within a 1000 miles. Ran a cheaper filter and synthetic oil but it did the trick. about a thousand miles later she cracked the oil pan pulling into a parking lot that had a huge hole in the ground. Mechanic replaced the pan and said the pickup tube looked good from the seafoam.
AAHHH...The wonderous lube of the GODS comes through again. I love that stuff. (SEAFOAM) LOL:p
 
1 - 5 of 5 Posts
Top