NewBeetle.org Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
okay so i have further insight to what is exactly going wrong with my car. Every time i crank the car and take off it goes great through every gear until 3rd. Once its in 3rd gear it stays in that gear the entire time and will not shift to 4th. unless you turn the car off or manually shift down but you only have 1st,2nd, and 3rd.. But the weird thing is, i can be driving and then BAM! the check engine light will disappear and the car fixes itself and then it shifts perfect as if it has never had any problems at all. its so random. but here lately the majority of the time its usually stuck in 3rd. anyone have an idea please. thank you so so much. sorry if this is considered a repost. could it be a shift sensor possibly or maybe even a ecm or wiring problem? thanks alot everyone.
 

·
5/23/10 <3
Joined
·
11,171 Posts
OP has the info filled out in their profile, if its the same car. '01 1.8T, which would be a 4-speed O1M.

But yes, get the car scanned for codes.
 

·
Registered
Joined
·
3,690 Posts
OP has the info filled out in their profile, if its the same car. '01 1.8T, which would be a 4-speed O1M.

But yes, get the car scanned for codes.
I was responding using my phone, so the profile info does not show up!

But the mileage is also useful as it gives you some idea if the unit can and should be repaired!
 

·
Registered
Joined
·
3,690 Posts
I would have to say valve body and valve body wiring harness on this one.

But at your mileage, you may be on the edge of a trans overhaul?

Kind of depends on what amount of metal and debris is in the pan, but as with anything it is a calculated risk you take.

Do you invest between $700-$1100 in this trans and hope it last long enough for you to get you investment returned?
 
1 - 6 of 6 Posts
Top