NewBeetle.org Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2003 turbo s beetle, I changed the fuel pump recently, the check engine light came on a while back and the code was a P1152-long term feul trim. I checked the mass air flow readings and it was not working properly. I changed the mass air sensor.
then a fuel pump relay fault code showed up. changed the relay.
Then a 17069 code for ECM power relay open circut intermittant along with 16519 for Oxygen sensor no activity.

I checked the oxyen sensor connections and changed the ECM relay.
the next under readiness came up Secondary air injection failed.
I checked the relay board and connections under the dash.
Then cleared the codes once again, then received a missfire cyl 1, 4, 2 apon restarting the car at idle.
I cleared those when finding no problems with coils or plugs.
I drove the car and it seemed fine but when a came to a stop it just died. restarted and continued and then parked idling and it died again. now a code for fuel level sensor open or short to intermittant.
Any suggestions????? where to go from here?
thanks
 

·
Registered
Joined
·
3,690 Posts
Some may tell you the crank sensor aka engine speed sensor is likely the issue.

It may be a possibility, however, you have a lot of strange codes and things happening at one time.

First thing I would do it pull the upper batter cover and look at the flip open fuse block mounted on top of the battery. Look for signs over overheating, melting or black terminals. This will be very obvious. The fuse block have had many problems and cause some strange things.

The other very slim possibility could be water/rodent damage around the ECU?? ECU is mounted in the cowl area. To access you remove the 3 front most dashboard covers, the the access panels under the dash covers.

Change the cabin filter and clean out all the trash in there while you are at it.
 
1 - 2 of 2 Posts
Top