VW Beetle Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
hey gang
having probs on our 99 turbo; the EPC light comes on & we don't have brake lights. I know the main culprit is usually the brake light switch, but today was driving & the EPC light is NOT on, & I do have brake lights. Then after about 15 min the light comes on again & no brake lights.
Any suggestions??
 

·
Registered
Joined
·
15,841 Posts
I would scan the car for trouble codes; sounds like what happened to my new beetle, when the brake switch went out. You might call your local dealer and see if the recall has been doen on your car, you might get yours fixed for free.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
It pulled:
1)P0140- bank 1 O2 sensor
2)P0139- bank 1 O2 sensor
3)P0411-secondary air injection system fault- the corrugated hose was unattached
4)P1118-heated circuit open bank O2 sensor
Plus the EPC light
 

·
Registered
Joined
·
15,841 Posts
You can look up the trouble codes here:

http://wiki.ross-tech.com/wiki/index.php/Main_Page

From what I have run across on my car; when the heater portion goes out, you have to replace the O2 sensor. Having said that I would try to test the O2 sensors with the scan tool; using live data you can see how they are doing. I would also try and test the O2 sensors using a voltohm meter; if you look in the service manual it will walk you through the testing process.


Sent from AutoGuide.com Free App
 
1 - 4 of 4 Posts
Top