NewBeetle.org Forums banner

1 - 6 of 6 Posts

·
The Leo Bug
Joined
·
34 Posts
Discussion Starter #1
So mine is an '04 it has about 94,000 miles on it. I have been having issues with my car loosing power randomly. It seems to happen when im sitting in traffic. My epc light comes on, sometimes my check engine light but not always. My rps will drop and I have no power what so ever. When I brake it, it feels stiff and when I let off the brake it will jerk forward a little, then accelerate really slow. If I turn my car off, sometimes it will not start up right away and I jave to give it alot of gas. Also sometimes it will happen when im driving down the road going 50-60 mph and it will jerk reall hard and I will loose power and acceleration. My husband thinks it might be my coil packs and/ or spark plugs. Does any one have any clues what it might be? I got some codes read and im going to look into that. I just wanted to see if anyone has had the same issues.
 

·
Certified Arcade Tech
Joined
·
416 Posts
Nice thing about the OBD II system is that it stores the codes even if the light goes 'off' for a long time.

This can give the group here 'direction' in how to assist you correctly. The codes most likely will be needed for others to review.

Sorry to hear that you're having issues with it. Hopefully we can work this one out.

S-
 

·
The Leo Bug
Joined
·
34 Posts
Discussion Starter #5
...

I replaced my spark plugs a few days ago and they did need to be replaced. it was fine for a few days then yesterday i was driving home from work and within a mile, the rpm's dropped, battery light came on, and i had no acceleration and my power steering was off. i had to slow to a stop. thankfully i was on a back road near my house and i wasnt going very fast. waited a few minutes, and tried to restart the car. it took a while but it started again. drove another few blocks and it happened again, this time my oil light came on. waited a few minutes, then started it back up. I went another few blocks and it happened a 3rd time! This time it just fluttered and it came back on in a few seconds and my EPC light and check engine light came on. I will have my sensors checked and/ or replaced. I really need to figure this out soon! :(
 

·
5/23/10 <3
Joined
·
10,967 Posts
1 - 6 of 6 Posts
Top