VW Beetle Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Okay so long story short when I bought my 2002 new beetle it had an issue with something to do with a ball joint being loose or something which was causing some knocking near the left wheel (my dad knows the technical name of it, I've completely forgotten!) which has now been repaired, but before it was done, if I had my wheels on full lock to the left, the ESP light would come on but go off if you restarted the engine.
Today I bumped up on the curb on the right side (not that hard though!) and the ESP light came on... And it won't go off.
My car is having its cambelt done along with other things on Wednesday so I can have it checked out but I was wondering if anyone has had this issue before as I'm really hoping it's not expensive (I've spent enough on it already since I got it in November!)
Anyone got any ideas?! :-(
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #2 ·
Just an update in case it helps anybody:
My VW specialist is absolutely stumped by the light! He has used his diagnostics thingy and it has come up with a few ideas, one is to do with the steering column but it won't let him reset anything like it usually does, possibly a wiring fault or could be a sensor ("Lateral Acceleration Sensor" being the most likely - but hopefully not as it could cost around £300).
He is going to carry on looking next week as he "will not let this beat him" ha, fingers crossed it'll be okay.
He managed to get the light to go out for 5 mins but came on again :-(
 

·
5/23/10 <3
Joined
·
11,412 Posts
Is he using a VW specific scanner like VCDS? It should be spitting out a code or two I imagine.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #4 ·
Is he using a VW specific scanner like VCDS? It should be spitting out a code or two I imagine.

Yes I assume so, he only works on VW's, audis and seats. Car has broken down today and won't start - I'm interested to know if it's related or not but I don't think it is. Booooo :-(
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #6 ·
Update... My car started fine this morning when I went to show our VW specialist what was wrong with it... Typical. Could be fuel pump, glow plugs or possibly starter motor. Don't think it's related to the ESP light though. This car is making me want to pull my hair out!!
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #7 ·
Update: no fault codes and no clue as to why my car wouldn't start the other day but most likely unrelated.

VW specialist is thinking it could be the steering angle sensor/slip ring! If this is the case we will have to get a secondhand part as the brand new ones are very very pricey!
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #8 ·
Update! It's all fixed!! Turned out to be a steering angle sensor. We got a used one for £50 and labour was only £40. No more ESP light! Woohoo!!
 
1 - 8 of 8 Posts
Top