NewBeetle.org Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
415 Posts
Discussion Starter #1
Hello Forum!

I just picked up a 2002 New Beetle GLS(I think by vin search). Odometer says 290k, but the engine looks pristine, new even. Seller said nothing of engine swap so I have no info on it. That's my second order of business after I chase down a AC system leak and a possible coolant leak.

This forum was very helpful, using as guest, to search for trouble codes and other good info. I hope to learn as much as I can to make my VW as enjoyable as I think it can be.

I appreciate any and all tips, help and teaching moments! Here to learn!

Thank you all in advance.
Xaiver


[/URL][/IMG]

[/URL][/IMG]
 

·
Bugabu
Joined
·
62 Posts
I had my A/C serviced and a all the fluids changed out and my wife decided to use it so now I'm looking for another Beetle. I may just unload and see about getting something very new.
 

·
Registered
Joined
·
415 Posts
Discussion Starter #6
Billy
I hate to say it but I don’t know. I do know these are ‘15 wheels, but haven’t pulled them off yet.
 

·
Super Moderator
Joined
·
14,724 Posts
Billy
I hate to say it but I don’t know. I do know these are ‘15 wheels, but haven’t pulled them off yet.
If I am correct, those are 18s or 19s! :eek:
 

·
Registered
Joined
·
415 Posts
Discussion Starter #8 (Edited)

·
Registered
Joined
·
415 Posts
Discussion Starter #9
Aside from that. I'm happy to report that after a little wrench time:
water outlet & gasket replaced
thermostat housing & gasket replaced
flush & filled with proper coolant (G12)
battery charged & load tested

My Beetle is running pretty good! No signs of any other coolant leaks and she's running nice and cool. I still a little leery about the fans. Mine turn on at 105c which, at least from watching EXOVCDS vids, they should kick on at 96c. :confused: Any advice with that would be greatly appreciated.

Also, the A/C system is screwed for now. There is a pretty serious leak, to the extent that the system won't hold pressure and there was a visible cloud when trying to charge the system. I got a guy for that, but he's out of town, so I'll be moving on the troubleshooting the sunroof and the "shaky" steering wheel at 65-75 mph.

Loving the forum so far, thanks to all that contribute!
 
1 - 9 of 9 Posts
Top