VW Beetle Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
I have a 99 beetle 2.0L 5 speed manual. (mexico factory)

The car runs fantastic and I'm currently averaging 27 MPG.

The engine light is on and two days ago I was getting codes P1472, P1425, P0134, P0341, P0135, P0102 and today I got even more codes.

I changed the Fuel Pump Relay (Napa) 2 days ago and the Relay blew yesterday while the car was idling in my garage, so I pulled the new relay out and installed the old relay and the car started right up. I returned the relay to Napa and the new one should arrive today.

Usually about 2 times a day the car will just die. The radio, clock and memory isn't lost so I don't think it's from a power failure. I think it is either flooding or being starved for fuel. It always start right back up after it goes dead and it never gives any indication that it's about to go dead. Usually after 20 minutes of driving the issue begins.

Also, when I turn on my directional signals they blink funny...skipping a blink and blinking fast but when I put in the Napa fuel pump relay, that issue stopped. The issue returned when I had to reinstall the old fuel pump relay.

ADD'L INFO: Yesterday I put new rear pads and rotors on the car (no issues), but when I was done and i go in the car, I started the car up, pumped the brakes several times and that's when the fuel pump relay blew. The car went dead several seconds later.

Any ideas??? :)
 

·
5/23/10 <3
Joined
·
11,605 Posts
Are you using a generic scanner? What are the other codes you've gotten? I can't find all the Pcodes, at least on the ross-tech wiki. I don't have my Bentley manual on hand to look them up. Generic scanners often will give wrong codes or tell you the codes mean the wrong thing. But from what you have, the 2 I could find...

16486/P0102/000258 - Mass Air Flow (MAF) (G70): Signal too Low
Possible Symptoms

* Probably no serious malfunctions
* Loss of power

Possible Causes

* Wiring and/or connections (short circuit?)
* Mass Air Flow (MAF) (G70) defective

Possible Solutions

* Check wiring and connections
* Check / Replace Mass Air Flow (MAF) (G70)

16725/P0341/000833 - Camshaft Position Sensor (G40): Implausible Signal
Possible Symptoms

* Malfunction Indicator Light (MIL) active

Possible Causes

* Wiring from/to Camshaft Position Sensor (G40) faulty
* Camshaft Position Sensor (G40) faulty
* Timing misaligned

Possible Solutions

* Check Wiring from/to Camshaft Position Sensor (G40)
* Check Camshaft Position Sensor (G40)
* Check Timing

Not sure if any of those would lead to your pump fuse blowing, but they could certainly cause problems for you.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #3 ·
I didn't record all of the other codes but there seems to be a theme with the codes 'poor electrical connection, short to ground', that's what led me to the fuel pump relay because so many things are tied to the fuel pump relay.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top