NewBeetle.org Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi I'm new to this form have a question hope someone can help I have a parasitic battery drain what I've come to figure out fuse 15 which controls the clusters and transmission control module. I have a 2005 Volkswagen beetle convertible, so I don't know if this is normal the speedometer takes like a clock and the speedometer hand moves a little bit does it all the time when the car is off when you remove fuse 15 it stops but warning lights come on if you try to start it. I figure this is the problem could use some advice also if anyone can tell me which is the ACC power line for the radio what color it is that would be very helpful thank you
 

·
Registered
Joined
·
12,326 Posts
Can you post a video; of the speedo cluster behavior? Have you scanned, for any trouble codes; using a vw specific scan tool, like vcds by Ross Tech. As to basic parasitic draw testing; check out this video.


Post up that video and we can go from there, thanks.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Thank you for the humble mechanic video I did try that sorry for the delay and the response I was out of town I took the battery to O'Reilly's to make sure it was a good opportunitybattery. Here's a video of what it does
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Thank you for the humble mechanic video I did try that sorry for the delay and the response I was out of town I took the battery to O'Reilly's to make sure it was a good opportunitybattery. Here's a video of what it does
Sorry for the late response I was out of town so I went to the battery chargers to make sure it was fully charged still doing it here is the video of it clicking and the gas gauge moving a little bit when you remove the fuse in stop the noise and stops moving I'm trying to upload the video doesn't allow me to
 
1 - 9 of 9 Posts
Top