VW Beetle Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
13 Posts
If you don't have that sweet smell when running your heat, I am inclined to say that your heater core is not leaking, but it may be clogged if you have a no-heat condition. I know admitting that your heater core is leaking is difficult; I lived in denial for a long time too even though I suspected my heater core was leaking coolant. You may have a small leak in the heater core if your windshield won't defrost. Any leak equals steam, which equals fogged windshield. However, if you are sure that your heater core is leak free, either your a/c is not functioning or your vents to the windshield are blocked. You are running your a/c when switching your mode switch to defrost, right?

Another item to consider is whether the foam cover on the temp blend door has fallen off. If you have seen pictures of the blend door, the piece of sheet metal that serves as the door has large pre-punched holes in it. Without the foam, that door cannot separate hot air from the heater core and colder, drier air from the evaporator. So you have more items to check before you can determine the source of the problem. I replaced the heater core in a NB due to a leaking heater core. It isn't a fun project, but it is doable by someone with decent skills and decent memory of what goes back where.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top