NewBeetle.org Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi all!

I need some help here.....

I start it, the rpm's drop and it dies. If I start it and keep the rpms up it will stay running.

My beetle is stalling anytime I stop, but if I ride the gears out it will stay running.

My 2000 beetle threw a code for a solenoid on one the generic OBD's. No one in our area has VagCom.

I have cleaned the MAF, I have also tried running the car with it unplugged.

The coil unit (mine only has one....) was replaced recently.

Sparks plugs are new.

Throttle body is fine

I did the crank and cam senors tonight. No avail....... I'm going to try hoses. It's clearly not from the throttle body. I also learned tonight that the codes are now, MAF low input and the o2 sensors have almost no power going to them.


O and the air pump runs when jumped but doesn't kick on by itself.........

HELP!
 

·
Registered
Joined
·
758 Posts
Instead of throwing parts at it, I'd consider buying a VagCom to help with diagnosis of the problem.
 

·
Registered
Joined
·
2,501 Posts
spark plug wires

Perhaps maybe your spark plug wires are shorting out to chassis ground or are bad. Did you remember to recalibrate the throttle bady valve after cleaning the maf sensor? After every repair involving sensors you should reset the ECU and recalibrate the throttle valve.....or drive it a while(one or two days) until the ECU relearns all it's perameters. There are instruction on those two important steps just do a search. Hope this helps ya out man.....Good luck.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Checked everything

I have checked and reset the throttle body and that didn't help I can't afford a VagCom otherwise don't you think I would have one?

It's not throwing any codes but the ones listed in the original post.
 

·
Registered
Joined
·
2,215 Posts
To do the throttle body adaption you turn the key to "on" without starting the engine and wait 30 seconds. Turn the key off. This teaches the ECU how to make the engine idle properly. Having a battery that is disconnected or run down for a period of time will cause the ECU to forget the setting.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
just remembered

Hi folks!

I just remembered that about 3 weeks ago every now and then I hear a very loud thumping sound under the car. It made this driving, or idling. Whenever the engine was revved.

I really appreciate any help that you can offer!!
 

·
5/23/10 <3
Joined
·
11,155 Posts
What were the code numbers? Should be a P#### code.
 
1 - 9 of 9 Posts
Top