NewBeetle.org Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
New beetle owner here just saying hi. I bought a 2000 red 2.0 beetle with 181k on it, ran ok when I bought it but since have replaced the fan switch, MAF, bank 1 O2 sensor, fuel filter, #4cylinder plug and wire and coil pack. The beetle is running good right now. I still have emergency brake cables to change and figure out why the vents dont blow air out of them. I have got lots of good info from this site so thank you all. See ya around.

Larry B:)
 

·
Go Blue!
Joined
·
293 Posts
Hi Larry :wave:

Welcome to the forums and congratulations on your new Beetle!
I'm also new around these parts, but from everything I have read you are in excellent company here :)
 

·
Premium Member
Joined
·
3,454 Posts
Welcome, take a moment and fill in your profile, show off your car and tell us more about why you love the Beetle! We love photos, hope to see some of your Beetle soon!


Sent from AutoGuide.com App
 

·
Apprentice Org-aholic!
Joined
·
1,470 Posts
Hey Larry. Glad to have you aboard. As stated, please fill out your profile, and dont forget to share some pics!! :)
 

·
T.O.D.7 Will U be there?
Joined
·
869 Posts
HELLO and WELCOME to the ORG!
Glad to have you here. Let's see some of your RED new beetle pix :p
Don't be shy....you are in good company here at the org.

ENJOY your new beetle:D

Welcome!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Thanks all

Thanks all for the welcome. I have updated the profile and put some pics of the beetle up. Still working on all the codes for engine and trans etc.
 
1 - 7 of 7 Posts
Top