NewBeetle.org Forums banner

1 - 20 of 40 Posts

·
Too Many Dubs....
Joined
·
160 Posts
Thanks pal.. If you only posted that up about 2 weeks earlier :D

I was taking out the panel under the steering column, and you have to take out the switch holder there to get the panel out. I took the back two screws out and fought with it a bit before I went and got the manual to find out there were two more screws hiding behind those derned caps.
 

·
Registered
Joined
·
7 Posts
Buggoff

You guys are the best! whenever I have a problem with my Bug I look it up on this site, print it up and voila! my husband can fix it. Awesome!!! keep up the good work.
 

·
my buggie is sexxahhhhh
Joined
·
22 Posts
hmmmmm well I replaced my hazard relay because the turn signals were flashing (and clicking) rapidly but none of the bulbs are out. Also when I turned the hazard lights on they flashed at the normal rate. Yet after replacing the relay the turn signals stillll are flashing viciously, I'm wondering if it's a fuse now or maybe there is a bad connection to one of the turn signals eventhough they all work. Well idk but if anybody has any ideas, all will be welcome just pm me because I lose track of threads, thanks!

oh by the way Tribangle great How-To!
 

·
Premium Member
Joined
·
11,013 Posts
dan said:
What about when the hazards work fine but the turn signals act funky? would this be a switch problem and not a relay problem?
Mine started out as just the turn signals. Try this, turn your indicator on and try to listen closely to the area that your emergency button is located. If it's louder than normal or if it buzzes at all I would replace it. First check all your bulbs to make sure :)
 
1 - 20 of 40 Posts
Top