NewBeetle.org Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 99NB, 2.0 gas, manual, 101+ miles.

The first time I started the car after not driving for a week and it had snowed in the Midwest, I noticed that the instrument panel was'nt working.

1) Engine Coolant Temp. light (blue) didn't show up on start as it should.
2) Speedometer, Tachometer, Fuel Gauge stays in 0.
3) Odometer & Trip Meter does NOT move.
4) ASR and Check Engine Light stays eluminated.

Car drives ok, no noise, everything else lights up, radio and alarm/keyless entry is fine.

Happened the first time and really concered. Its hard to drive not knowing if you still have gas and how fast you're going.

Oh, a few times before, the trip meter would reset to 0 by itself on start. Ignored it coz it didnt seem to be that big of a deal. But this collection of problem is something else!

What could be the problem? How much would it cost?
This is my 1st car and clueless. :eek:
Please help!
 

·
Delightfully Tacky
Joined
·
1,526 Posts
two options...


1) if you have vag com or know of someone with it get a used working instrument cluster and have it reprogrammed to work with your vehicle


2) go to the dealership and give them anywhere from $505-$658(prices i was quoted for bad instrument cluster) to install and reprogram a new cluster in your car



you can try replacing fuses but i doubt it is that...good luck


someone might have better news for you..this is just what i have found trying to figure out the same problem on my 98 2.0
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Assuming I need a new instrument panel, if I buy online, will the dealer put it for me? How much? Can an independent shop do it for less?

Also, together with the instrument panel malfunction, the temperature on my rear view mirror stopped working (stuck to 19F).

Im very frustrated!
 

·
Delightfully Tacky
Joined
·
1,526 Posts
azncharm said:
Assuming I need a new instrument panel, if I buy online, will the dealer put it for me? How much? Can an independent shop do it for less?

Also, together with the instrument panel malfunction, the temperature on my rear view mirror stopped working (stuck to 19F).

Im very frustrated!
ill let you know..im about to call my dealership and see..from what i have learned in the past most dealerships wont use customer supplied parts for anything...your dealership might be different though
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
I noticed that you're from St. Louis, MO. The dealer I go to is the VW Dean Team of Kirkwood. I didnt buy the car there but thats where I go for parts/repair.
 

·
Delightfully Tacky
Joined
·
1,526 Posts
azncharm said:
I noticed that you're from St. Louis, MO. The dealer I go to is the VW Dean Team of Kirkwood. I didnt buy the car there but thats where I go for parts/repair.
thats the place that quoted me $505 and who will be doing the work for me :D everywhere else in the area was $550+ for that


ill be purchasing vag com soon(hopefully) and will be able to help ya out with anything until mid january ;)
 

·
Delightfully Tacky
Joined
·
1,526 Posts
http://newbeetle.org/forums/showthread.php?t=2843


http://www.dub-tech.com/forums/showthread.php?t=6948


these are the threads that i have started...you can register on that dub-tech.com board but i think you have the same problem that i do..with your speedo and things cutting out as well it might be the sending unit for it


it was $100 at the kirkwood dealer to run diagnostics...at least that way you are 100% sure what it is and not spending all kinds of money because someone over the internet said that it could be one thing or it could be another..the dealer will tell you EXACTLY what is wrong with it...

ill be up at kirkwood tonight around 6 getting mine fixed..maybe they can do a two for one deal and we can split it :D
 
1 - 8 of 8 Posts
Top