VW Beetle Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I am in desperate need. My instrument cluster (speedo, rpm, fuel gauge) is not working. I've checked all the interior fuses and they are good. Also when I start car I get an annoying beep that lasts for about a minute before it stops. Turn on headlights same beep for about 2 minutes. When I shut driver door light remains on. Could all these malfunctions be related? Also AC/heater doesn't come on. PLEASE HELP ME :(
 

·
5/23/10 <3
Joined
·
11,412 Posts
Sounds like at least the buzzer is related to your door switch thinking the door is always open. Common failure. I don't have the links on hand, but there is a TDIClub and VWVortex post on the microswitches.
 

·
Registered
Joined
·
15,839 Posts
Hey, please fill out your info; that way we can help you more intelligently: e.g. where you are, year, model, engine, trans, etc. Getting your car scanned with a VW compatible scanner; see if there are any trouble codes. Post them up here; we will do our best to help.The speedo clusters; can be repaired, you can ship it out and reinstall when repaired, job complete. With VCDS you can do some output tests; to see if the gauges are working by themselves. Getting a used one; will usually require programming and matching processes, that require the use of vagtacho and vcds, a pretty involved process (having yours repaired; is the easiest and most cost effective solution, if you have a immobilizer 2000 models and later). Typical vendors: BBAREMAN, http://clusterfix.net/, etc.

https://www.google.com/webhp?source...e=UTF-8#q=vw new beetle speedo cluster repair
 
1 - 3 of 3 Posts
Top