NewBeetle.org Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I installed the 57i performance air intake on my 04 turbo s. It makes cool sounds and all but I feel like it might’ve made my car slower? I tried to time my 0-60 and it’s getting like 9-10 seconds and it should be around 7 seconds. what’s going wrong? I also have a catless downpipe
 

·
Registered
Joined
·
13,128 Posts
What other upgrades, have you done; along with the intake? I would assume, to take full advantage of a better flowing intake; other parts, would need to be improved, as well?

The stock airbox, is said to be well engineered and has good flow charecteristics, PLUS it actually gets "cool" air, from outside the engine compartment. Many of these aftermarket "COLD AIR INTAKES", really are not, as the name implies but take hot air from the engine compartment. Is this the kit; you installed? K&N 57i Intake Kit (02-05 A4 1.8T)

These "CAI", upgrades; seem popular but real world performance, may not always be a improvement, as assumed. Money, could probably be better spent; on better bag for the buck upgrades, like a software/chip upgrade.

As for K&N, I put one of their "drop in" filter in my stock 1.8T and it make a difference, not bad for about $50.
 

·
Registered
Joined
·
13,128 Posts
Most of the 1.8T's on the road; are not running correctly or at their best performing level. They typically, have a wide range of old, under performing parts installed and need some testing, a "tune up" of sorts, to get them running, well. Beleive it or not; a correctly running AWP 1.8T, runs very well and many things, should be checked. Get the car running right first and then, start adding upgrades, as time and money, is available.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Most of the 1.8T's on the road; are not running correctly or at their best performing level. They typically, have a wide range of old, under performing parts installed and need some testing, a "tune up" of sorts, to get them running, well. Beleive it or not; a correctly running AWP 1.8T, runs very well and many things, should be checked. Get the car running right first and then, start adding upgrades, as time and money, is available.
I just figured it out hahaha, the ground for my alternator was completely melted so everything was just slowly losing power in my car and now it doesn’t turn on anymore
 
1 - 6 of 6 Posts
Top