NewBeetle.org Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
so, my fiancee's 2000 beetle (70k miles) is sitting at the dealer waiting for vag-com diagnosis for a thrown cel. she has had the maf sensor replaced in '01, '02' and '03, the o2 sensor replaced in '02, and a vacuum hose replaced in '04. wtf?!?

i've never had to replace MAF sensor in any of my cars, so what exactly is the average lifespan? i have to think it is longer than a year!

i've read a lot of reviews here and elsewhere and this seems to be a reacurring problem with the new beetle. you'd think vw would issue a recall. imo, this is one of the many problems with this car (along with the inability to change you own battery! yes, we experienced this this winter)

now that her warranty has long passed, i am advocating for her to get a new car, preferably a mazda3. something reliable and warrantied, soemthing i am familar with, and something to last her tuntil she gets out of law school.

sorry for the rant, i am just really pissed at vw right now. we're both in school, getting married in aug, and don't have money for all these repairs. but i would like to know what is up with the MAF sensors so i can be more informed before talking to the service tech. thanks all.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
yes, as they are oem parts, all purchased and installed at vw dealers. they just decide to crap out after about a year.

thanks for the info.
 

·
I bleed Burnt Orange!
Joined
·
687 Posts
Do you have a K&N filter? Those have been known to interfere with the MAF if any of the oil in the filter gets sucked into the MAF.
 

·
Premium Member
Joined
·
270 Posts
just be happy your not in a jetta/golf/gti cause the prices on those were not dropped. your looking at $175 on sale at impex (http://www.worldimpex.com/item_detail.html?sku=117548) VW reduced the price on our MAFs.

Try cleaning yours with Electical spray cleaner! Take MAF off, spray cleaner on inside and on plug area.. let dry install. Sometimes this makes all the difference.

K&N as mentioned can kill it esp. if you over oil the filter after cleaning.

I know from experience that if you get your MAF from the dealer and they dont install it, it voids warranty on it!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
dgoldbe2 said:
Do you have a K&N filter? Those have been known to interfere with the MAF if any of the oil in the filter gets sucked into the MAF.
no, no k&n filter. everything is stock on her car.

called the dealer and nothing hit on the vag-com, which is surprising considering how the car ran (enigine sputtering, low gas mileage, etc.). so they turned the cel off and we pick it up today. i dunno, perhaps bad gas (unlikely, though, as she last filled up at the same shell she always uses and there's never been a problem).

just not sure we're going to keep it. too many problems and soon she'll need new tires and rear brakes. the ~$400 for battery replacement and 60k mile service was enough. time to stop the bleeding. :)
 

·
20V GTRS
Joined
·
1,120 Posts
jsherrill28 said:
called the dealer and nothing hit on the vag-com, which is surprising considering how the car ran (enigine sputtering, low gas mileage, etc.). so they turned the cel off and we pick it up today.
Something does not sound right here, no hit on a VAG-COM, but the CEL was on.? :confused: :confused: For the CEL to come on there would have to be a fault.
 
1 - 9 of 9 Posts
Top