NewBeetle.org Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey there fellow beetle owners,

I own a 2002 Yellow Beetle and it has been running fine for the past couple of weeks...a few weeks back my car started to rough idle and the check engine light came on after it started to rough idle and I was driving. The next day after I tried to start my car it acted like it was going to start and then it died..the day after that my car was completely dead and I had it towed to a repair shop in Raleigh that specializes in foreign cars and mostly VWs. Anyways after they charged my car and got it running again the diagnostics they did on it was popping out a code saying that the reason for the rough idle and the check engine light coming on would have to do with my throttle body in some way. They were going to due further diagnostics on it when somehow my car after being turned off and then turned back on was acting completely fine. The repair man, who has been working on VWs for over 30 something years couldn't even explain technically how and why it started acting fine again other than somehow my car reset itself someway.

Anyways, that happened a few weeks back, and since then my car has been working just fine. Yesterday, around evening time my Beetle's check engine light came on, but my Beetle wasn't acting up at all besides the light coming on. This morning when I turned my car on the check engine light still stayed on, but my car was still running fine. I took it to Auto Zone where they hooked up their little diagnostics machine and it the machine showed the code P0420 and no other code. After leaving there, with my check engine light still on and my car still running fine, I went to drive to get gas and drive to class. Somewhere between leaving Auto Zone and getting gas my check engine light went off. So now the check engine light is off and my car is still running good. I think I'm still going to take my car to get checked out a little more either tomorrow or sometime this week. I thought I would run what is happening by yall to see what yall thought and what it could be. I'm not that car savvy, so if you could break down anything mechanical you are talking to me about..trying my best to become my car knowledgeable! :)
 

·
5/23/10 <3
Joined
·
10,920 Posts
P0420 is usually a failed catalytic converter. Noticing any rattles? Any odd smells? Fuel economy dropped?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
P0420 is usually a failed catalytic converter. Noticing any rattles? Any odd smells? Fuel economy dropped?
I haven't noticed any rattling, odd smells, or fuel economy dropped. Exactly what does "Fuel Economy Drop" mean?? Auto Zone also printed me out a receipt with the code on it and the definitions of the code. I'll write below what it says on the receipt of all the definitions for the code word by word.

Definition of code P0420:
-Catalyst system efficiency below threshold bank (1 explanation)
-Faulty Catalytic Converter (probable Cause)
-Rich Air/Fuel ratio
-Air leak near rear H02S (Heated Oxygen Sensor)
-Faulty fuel control H02S (Heated Oxygen Sensor)
 

·
5/23/10 <3
Joined
·
10,920 Posts
Has your gas mileage gone down is what I mean by that. Any failed or failing emissions components usually are coupled with a drop in your fuel economy. I lost 2-3 mpg when I had a failing, and ultimately failed O2 sensor. I had serious rattling when my cat failed, and had that exact code.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Has your gas mileage gone down is what I mean by that. Any failed or failing emissions components usually are coupled with a drop in your fuel economy. I lost 2-3 mpg when I had a failing, and ultimately failed O2 sensor. I had serious rattling when my cat failed, and had that exact code.
I don't believe my gas mileage has gone down any..do you mean just like losing gas quicker than normal?? I just got back from having to go somewhere and my Check Engine Light hasn't come back on and my car seems to be acting fine. I drove with the air off and radio off so I could listen to my car and I don't hear any rattling noises. (I'm guessing I would know the rattling noise your talking about and be able to identify that noise if I heard it?) Also haven't smelled anything different coming from my car and I'm guessing my gas mileage is fine. I don't know if my car just randomly did that, but regardless of it not coming back on since this morning it still kinda freaks me out that something could be up with..and since when I took it to Auto Zone it gave out that code. Would you suggest taking it in to get looked at sooner rather than later?? I just don't want anything to go wrong with my car if something could go wrong with it or if something could get worse than it is if there is something wrong with it already. I'd rather have to get something repaired or replaced now while it's minimal rather than if it is to get worse and have a bigger problem to fix.
 

·
5/23/10 <3
Joined
·
10,920 Posts
I take it you don't keep track of your MPGs? That is a good way to start troubleshooting when it comes to things potentially relating to failed emissions components.

If you are thinking of taking the car to a shop at all and you are willing to take it Raleigh again, I'd go to Apex Tuning. Excellent shop and they will take good care of you. I don't like that the shop you took the car to didn't seem to know what was going on. I'm a part of a local VW forum and that shop is not mentioned at all on there so I have no idea if they truly are a really reputable shop. I trust Apex 100% with all of my VWs (took my NB there [they let me keep the wrecked car there until I settled with insurance too], taken my GTI there and they do work on our '84 Jetta as well).

If you aren't noticing much strange, then I'd keep driving the car and see if the CEL comes on again. If the cat or an o2 sensor is failing, its already on its way out so its not going to matter too much. I drove around with my cat rattling for 6 months with no ill side effects (no CEL until the last week or so, I assumed it was a loose heat shield until the light came on) and drove for a good 6 months+ with a failing O2 sensor.
 

·
Registered
Joined
·
2 Posts
2002 Vw problems

I have a 2002 vw 2.o AutoZone scanned and I am getting P0041 and P0036 H02S bank 1 and 2 sensor 2 How do I fix this can it be done myself I also have a code P1296. can anyone help: nblove:
 
1 - 7 of 7 Posts
Top