VW Beetle Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
Hey, so I bought this new beetle (1999) not too long ago, so guy told me of this problem before I bought it, he told me its the distributor cap, idk if its true, i should have indeed inspected it before buying it but oh well..

Anyways heres the problem, especially when it's cold, the I turn the key, it cranks for a while then turns on, has some difficulty staying on then shuts off, then I have to restart it a few more times until it finally stays on and works. Also everytime it starts it makes like a quick screetch noise..

Help? Is it true its the distributor cap or is it something else?

Thanks
 

·
5/23/10 <3
Joined
·
11,412 Posts
Have you scanned for codes? Checked the charging system? Starter?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Have you scanned for codes? Checked the charging system? Starter?
Haven't got the chance yet, guy gave me a garanty on 3 months if engine has issues because of the check engine so I took it lightly, but today the oil light came on for the first time, Have to check my levels now
 

·
5/23/10 <3
Joined
·
11,412 Posts
There is no distributor on these cars. There is an ignition coil pack instead.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
There is no distributor on these cars. There is an ignition coil pack instead.
Yeah that's what I found out today.. could that be the cause though? Because for example when it's really cold, I'd have to crank the car atleast 3-4 times before it stays on but once it's warm and I turn it off and back on it fires up right away
 
1 - 7 of 7 Posts
Top