VW Beetle Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Glad to be part of new beetle forum. Decided to join. I use this site a lot. Dropped my car off yesterday at mechanic to diagnose serious power failure. Telling me I need a totally new computer. Doesn't sound right to me.$1600. Anyway, hopefully I can find some answers and possibly share my experiences. Or maybe it's time to trade.
 

·
Registered
Joined
·
2,101 Posts
ECMs are cheap! Theres one right now in parts and accesories for the AEG motor,it has a performance tune already installed for 250 dollars. Get your car back.Do not be misled!ECM swap is easy,we can walk you through it. This gentleman is not an honest mechanic if that is all he is going to do for you! Run! I sure hope he doesnt charge you more than 1 hour to diagnose. Besides ECMs rarely fail. Take your car to a mechanic with a good reputation. There are many crooked crooks out there who will be glad to relieve you of your hard earned money. I see these horror stories unfold on a weekly basis,and the outcome is not pretty for the consumer.:( Let us help,that is why we are here.:)
 

·
Registered
Joined
·
18 Posts
Glad to be part of new beetle forum. Decided to join. I use this site a lot. Dropped my car off yesterday at mechanic to diagnose serious power failure. Telling me I need a totally new computer. Doesn't sound right to me.$1600. Anyway, hopefully I can find some answers and possibly share my experiences. Or maybe it's time to trade.
So what were the symptoms? Its not starting, it stops when running or what. Power failure has nothing to do with the ECM it has to do with the battery, fuses or alternator. Relay 109 is a failure waiting to happen, if you have the OEM one it should be replaced, less than $20 and a couple screws.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thank you so much

This is why I love this forum. Thank you for responding. My beetle started a pretty serious power failure 2 weeks ago. About two miles from my house, it started feeling really really sluggish. I thought perhaps the colder than usual weather was to blame. I would push the gas and no response. It was running but almost zero pickup. I drove it for 2 more miles and was seriously pushing the petal, then finally it just took off like it was congested, and got something out of it's system. I drove it directly to the mechanic, told me needed a new PCM, in his words "computer" and the part alone would cost 1300$.. I started looking for a new car because I thought perhaps it was shot. So this morning..car hasn't been started for a few days, I went to turn the key and it would not start. It tried to turn over, however it felt like that seriously sluggish feeling a couple weeks ago. I noticed the smaller air tube connecting to the air filter was unplugged. It didn't make a difference when I reconnected. So after a number of attempts to start the car, I unplugged the Electrical connection to the maf sensor, and guess what.. The car started. Felt almost normal. I plugged it back in and the car stayed running. So I just came back inside the house to report my issue here. One side note, the car has been losing coolant significantly. I add more once a week. I have tried sourcing the leak to no success. The mechanic I brought it to couldn't find it either after running the car for a while. But that's not a surprise, he probably just hooked the car up to the terminal and read codes he didn't know what to do with. Last year I did replace the radiator and one of the radiator fans. What a job. I also built my own alternator harness because my fuse box kept melting and the car kept shorting out. It seemed to have worked, however I can no longer charge my phone with the lighter outlet. It actually drains my phone battery instead. I know there is a lot of issues here, however I am not afraid to take on these projects. Thanks again for helping me. The way i see it, You are a true blessing from God. .
 

·
5/23/10 <3
Joined
·
11,236 Posts
Sounds like you need to find a new mechanic! Doesn't seem like he knows VWs at all.

How many miles on the car?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Miles

It has 138000 . 98 gas 2L . Manual trans. I agree, I think the mechanic just made 100 dollars because he didn't want to deal with it. What kills me is that I specifically asked if they knew these cars before bringing it his shop.
 

·
5/23/10 <3
Joined
·
11,236 Posts
Where are you located?

Do you know when the timing belt was done last? Leaking coolant could be coming from a failing water pump.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
Last time water pump and timing changed

I'm not sure when the timing belt was changed last. The person we purchased the car from swore that he had a certified vw mechanic change everything within a few months of our purchase. i doubted that since the serpentine belt looked like snakeskin.

I think I found the leak. first time i could actually see it with my eye. I am posting the pictures here.
 

Attachments

1 - 10 of 10 Posts
Top