VW Beetle Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello!

I have been having a very strange and upsetting issue with my little 98 Bug 2.0 L.

The oil sensor light comes on, beeping VERY loudly for a moment or too. After having a typical girl-who-doesn't-know-anything-about-cars freakout, I started looking around. I have been checking my oil once every two days and keeping my eye on the spots I've parked for any leaks. I am not losing oil. The manual said this sound and flashing light indicates low oil pressure. The last two times I've gotten my oil changed, they said the oil pressure is fine.

When reading through these forums, I've read that when my blue coolant light comes on, flashing, WITH the oil sensor, this is actually an indicator that my Coolant Sensor Unity is going bad and that replacing it can fix this issue. Well EVERY single time the oil sensor has come on, my coolant light has been flashing. And it even comes on without the oil sensor light as a pair.

I bought the part, intending to switch it out myself because everyone is saying it so easy but now I'm worried I got the wrong part.

Additionally, I have felt like my car is extra smelly when I'm driving it around. Kinda like burning oil or coolant but the smell dissipates really quickly and I still don't have any missing coolant or oil or any leaks on the ground so I'm confused if this smell is related to the coolant issue?

Or if I need to replace the oil sensor unit (which my understanding is, similar item just different spot and purpose).

This is the part I bought:
https://c1552172.ssl.cf0.rackcdn.com/52713_x600.jpg

And I believe I located the correct item to replace. I just don't want to replace something if it's not broken? Though I guess it IS old and could be replaced by now?
 

·
5/23/10 <3
Joined
·
11,357 Posts
That's the correct part - the coolant temp sensor. Make sure you get a new o-ring and clip too.
 
1 - 2 of 2 Posts
Top