NewBeetle.org Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Today I was sitting at a stop light oil light started blinking along with a chime. Also at the same time the blue temperature light came on. If the engine is running over 1500 rpms the oil light goes off. The blue temp light starts blinking. Any help would be appreciated with this problem.
 

·
dub-tech.com
Joined
·
13 Posts
Let me get this straight...the oil light is flashing at idle (how is the oil level? how often has it been changed?) and at the same time the blue temp light is on...then, upon revving up, the oil light goes out and the blue temp light starts flashing blue? What year/engine?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
1999 1.8turbo 125,000
The oil level is good and was changed about 600 miles ago. All oil changes have been with Mobil 1 since I have had the car which has been about 3 years and 40,000 miles.

Yes the blue temp light starts blinking when the oil light turns off. The car was definitely warmed up because I had driven about 10 miles and it is not that cold here. The blue temp light came on before the oil light came on. It seems that when the blue temp light is not on at all that the oil light does not come on at idle.

Thanks for your help.
 

·
dub-tech.com
Joined
·
13 Posts
Definitely an odd problem, I almost wanna say bad cluster as they are soooo common. However, unplug your coolant reservoir and look inside the plug. Is there coolant inside the electical connector?
 
1 - 4 of 4 Posts
Top