NewBeetle.org Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Ok my daughters VW 1998 Beetle 2.0 has been a pain a neck. First time it overheated I replaced the fuse block on top of the battery everything was ok for a awhile a year or so. I replaced the water pump and timing belt right when she got the car used at 72k miles. Then several years later replaced water pump again at like 90K miles and timing belt, and timing belt tensioner as I was afraid her pump was going to quit again as the plastic pump impellers being junk. Well this past spring car was overheating, but pump was flowing so I changed the thermostat, car still overheated. So then I changed the fan control box then car seemed fine all this summer. Now her car was overheating again. I found leak at water pump replaced water pump with a new metal impeller pump. It was the water pump o'ring leaking as it was very flat from car overheating. The car killed the battery and the fans were stuck on when I got to the car. Charged the battery and tested originally fans in the a/c position both fans ran but would not come on from the car heating up. I then changed the fan control switch at bottom of radiator still not coming on. Jumpered the fan switch to command the fan relay box to start fans no fans. First time I jumpered the fan switch one to two on the pins got one fan. Jumpered the two to three pins nothing. Now after testing the fan control box by jumpering the radiator switch no fans whats so ever. The fan control relay box was a new VW part made in Hungary. Could this box be bad already like just a month or two? Or should I be testing the fans? :(
 
1 - 2 of 2 Posts
Top