NewBeetle.org Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
30 min journey yesterday took me 2 hrs had to keep stopping every 5 mins the red temp warning light was bleeping and flashing.........also water leaking from drivers side(right hand drive) seemed to be comming from underneath or around the area of the resovoire not really any steam or smell.......engine sounds a little different.....cars done 65k hasnt had water pump timing done yet etc?......any ideas guys would be greatly appreciated also heating is not as warm as usual .....:confused:
 

·
5/23/10 <3
Joined
·
11,155 Posts
If it is overheating and flashing the red temperature light, first things first...do NOT drive it anymore! When that happens, you really should pull over and call a tow truck. There is a reason its beeping at you :) And I would say its the water pump. Its common for them to fail around 60K, as they have plastic impellers that just break apart. But I could be wrong.

The only thing I know is, as long as its overheating, don't drive it!
 

·
Registered
Joined
·
48 Posts
Discussion Starter #4
cheers guys bug now with machanic.........will let u know the outcome:confused:
 

·
Registered
Joined
·
48 Posts
Discussion Starter #5
having water pump changed, timing belt and tentioner, serpentine belt and tentioners!!!! £290.00 good bargain!! especially here in uk!!
 

·
Premium Member
Joined
·
2,714 Posts
That seems like a fairly cheap repair. At least it was sorted before something went further.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #7
pray that its nothing else!!!! read some horror stories on here about head gaskets etc.........2001 only 65k i should be ok right???????
 

·
Registered
Joined
·
48 Posts
Discussion Starter #8
seems that it was the waterpump after all...........still had timing and serpent done as precaution
 
1 - 9 of 9 Posts
Top