VW Beetle Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
I know the "secondary air system - incorrect flow" message is a very common problem on the beetle and a very common topic on this forum. I have been reading many posts in the last few yrs, however I think my case should deserve a dedicated post.

A couple of years ago the P0411 message came out. I red posts and found out that the rivets of the sec air pump were cracked. I fixed them per the instructions, reset the ECU and I passed my emission test.

However, after 1 yr the message came back. I checked the vacuum lines and the solenoid valve and they were fine. No emission test required so I ran the car for few months with it, trying to figure out the reason.

When new emission test was approaching I spent more energies on it and ended up replacing the combi valve, which was stuck. Thank god this fixed it and I passed again the emission test.

After few months it was the time of the downstream oxygen sensor to fail. Replaced that.

However, again few weeks and P0411 is back! I said screw it and ran for a while with it. Until when my secondary air pump starter screaming like a child. Every morning when pulling out of the driveway i was waking up the all neighborhood with my screaming pump.

Therefore I bought on ECS tuning a brand new pump and new vacuum lines. I replaced the pump (it is not that difficult at all, you just need to pull out the screws holding the pump bracket and then take off the pump + bracket), replaced all the vacuum lines, checked and cleaned the vacuum components and the combi valve operation. Everything looked good!

I reset the ECU and ran like a charm...... for just a week! Then CEL comes on and again P0411 is there. I reset the ECU and after two weeks again is back....

So, at this point I am really lost. What else can I check or replace?

Secondly, is it strange that if I clear the error it does not come back immediately but takes days or weeks? I hear the pump kicking in every morning (going to work) and night (coming back) and I drive it every day. If there was something consistently wrong, shouldn't the error come back right away?

Thanks folks for your help and support... I really need it......
 

·
Registered
Joined
·
15,844 Posts
Start with the basics; have checked and tested, all of the items on this list?

16795/P0411/001041 - Ross-Tech Wiki

Please fill out your profile info for your car; that way we can help you, in a more intelligent way! Thanks! :)
 
1 - 2 of 2 Posts
Top