NewBeetle.org Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I'm new to this site. Trying to find my way around, but need some help deciding whats wrong with my pass side door lock.

I can use my remote to lock and unlock both of my doors. The LED light turns on and off, but my pass side lock knob does not go down. Not even if I force it. Plus, every time I hit about 20mph it trys to relock the door, because it thinks its not locked because the knob won't go down.

I am going to take the door panels off and take a look, but I do not want to do that and then get stuck with needing a part. I would like to try and know what I need to look for.

HELP!!!

Is it the switch? the module? the actuator?
I've never seen inside the black metal panel.
 

·
Premium Member
Joined
·
4,753 Posts

·
5/23/10 <3
Joined
·
10,918 Posts
I'd get into the door and see if there is anything going on with the physical lock knob.

Are you having any problems with your door lights at all on the passenger side?
 

·
Premium Member
Joined
·
4,753 Posts
I'd get into the door and see if there is anything going on with the physical lock knob.

Are you having any problems with your door lights at all on the passenger side?
I'm reading the problem IS with the pass door.
 

·
5/23/10 <3
Joined
·
10,918 Posts
Yup, just asking if that door has any problems with the lighting, which would also indicate a microswitch problem. :)
 

·
Premium Member
Joined
·
4,753 Posts
Plus, every time I hit about 20mph it trys to relock the door, because it thinks its not locked because the knob won't go down.
This is a normal function, is it trying to lock the doors (and can't), or is it locking the doors?

After re-reading your post, and doing a little thread searching and more reading, I think it is probably a problem with the door lock assembly. I have attached the basic Bentley diagnostics below.

Here is what you should find when you get into the door, in reverse of course
 

Attachments

·
Registered
Joined
·
3 Posts
Discussion Starter #7
GET THIS...

The plastic knob was getting it caught up. I removed the plastic knob (Which twists off the melt rod) & it worked.

So right now there is no cover, but it works. I think I am going to go get a smaller universal one.

I never even had to take off the inner black handle!

WindowRegulator2.jpg
(Used picture from someone else)
 

·
Premium Member
Joined
·
4,753 Posts
Glad you found the problem, well the cause, not the problem. What could be happening, is that the knob had become partially unscrewed, raising it above the guide stem. It should not be hanging up all of a sudden for no reason. Did you try screwing it on further?

M.
 
1 - 8 of 8 Posts
Top