VW Beetle Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter · #1 ·
Hello all, 03 NB 1.8T, Bought last September, passenger window hasn't worked since we've had it. Took pass panel off, unbolted motor, getting a click, but motor not turning. Bought a junkyard motor for $11, (U-Pull It yard so I don't know if it works or not) plugged it in, still just a click, not turning.

So I then took the driver's panel off (window works fine on that side) and plugged both original pass motor and JY motor in, still not turning. I left all of the switches / sensors plugged in during the test.

I know that the JY motor was a gamble (I can return it within 30 days) but thought I'd try it- only 11 bucks. Plus it's always fun to go to the junkyard! Guess I'm wondering if I should buy an eBay known functioning motor, or are there some test steps I've neglected. Seems that if either of the motors were good they would have worked on the driver's side harness.

Thanks in advance! Dave
 

·
Registered
Joined
·
112 Posts
Discussion Starter · #3 ·
motor

D2- actually I did not try that, the driver's window is working perfectly, I didn't want to disturb it by taking the motor out.

There is a local beetle being parted out with a currently working passenger side window. gonna pull it this weekend and plug it into my beetle, see what happens... Dave
 

·
Registered
Joined
·
112 Posts
Discussion Starter · #4 ·
Window

well i did some testing with another New Beetle with known functioning windows. To make a long story short, my passenger motor and switches worked in the other beetle. So I think my switches and passenger side motor are all ok.

But passenger side motor won't work when i plug it into the plug on my passenger side door.

guess i'll look for broken wires somewhere...
 
1 - 4 of 4 Posts
Top